Max Sum Plus Plus

Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

 

Author
JGShining(极光炫影)
答案:
#include <stdio.h>
#include <string>
#define max(a, b) a > b? a: b
#define max_num  1000000+50
int m, n;
int v[max_num];
int now[max_num];
int pre[max_num];
int maxcalc()
{
 int max_pre;
 
 memset(now, 0, sizeof(now));
 memset(pre, 0, sizeof(pre));
 for (int i = 1; i <= m; ++i)
 {
  max_pre = INT_MIN;
  for (int j = i; j <= n; ++j)
  {
   now[j] = max(now[j-1]+v[j], pre[j-1]+v[j]);
   pre[j-1] = max_pre;
   if (max_pre < now[j])
    max_pre = now[j];
  }
 }
 return max_pre;
}
int main()
{
 while (scanf("%d%d", &m, &n)!=EOF && n && m)
 {
  for (int i = 1 ; i <= n; ++i)
   scanf("%d", &v[i]);
  printf("%d/n", maxcalc());
 }
 
 return 0;
}
超时的迭代穷举法:
#include <stdio.h>
int m, n;
int v[1000001];
int max;
int maxsum(int i, int j)
{
 int maxs = 0;
 int d = 0;
 int k, f;
 for (k = i; k <= j; ++k)
 {
  if (v[k] <= 0)
   continue;
  
  d = v[k];
  for (f = k+1; f <= n; ++f)
  {
   d += v[f];
   if (d <= 0)
    break;
   if (d > maxs)
    maxs = d;
  }
 }
 if (maxs == 0)
 {
  maxs = v[i];
  for (k = i+1; k <= n; ++k)
  {
   if (maxs < v[k])
    maxs = v[k];
  }
 }
 return maxs;
}
void caculate(int st, int& sum, int sm)
{
 if (sm == 1)
 {
  int s = maxsum(st, n);
  sum += s;
  if (max < sum)
   max = sum;
  sum -= s;
 }
 else
 {
  int s = 0;
  for (int k = st; k <= n-sm+1; ++k)
  {
   s += v[k];
   sum += s;
   caculate(k+1, sum, sm-1);
   sum -= s;
  }
 }
}
void solve()
{
 int sum = 0;
 for (int k = 1; k <= n-m+1; ++k)
  caculate(k, sum, m);
}
int main()
{
 while (scanf("%d%d", &m, &n)!=EOF && n && m)
 {
  for (int i = 1 ; i <= n; ++i)
   scanf("%d", &v[i]);
  
  max = 0;
  solve();
  printf("%d/n", max);
 }
 
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值