Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
Sample Input
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
Sample Output
6 5 3 1 2 1
Author
CHEN, Yue
Source
Recommend
Ignatius.L
分析:问题的实质是求N个序列中的前k个大的数,要考虑到效率问题!
参考代码:
#include <iostream>
using namespace std;
#define N 301
int sortknum[N]; // 记录前k个数的降序的编号
float satisf[N]; // 对应编号的的满意值
int n, m, k;
float satisf[N]; // 对应编号的的满意值
int n, m, k;
void swap(int& a, int& b)
{
int tmp = a;
a = b;
b = tmp;
}
{
int tmp = a;
a = b;
b = tmp;
}
void init()
{
int i, j;
float tmp;
{
int i, j;
float tmp;
for (j = 1; j <= m; ++j)
{
satisf[j] = 0;
if (j <= k)
sortknum[j] = j;
}
{
satisf[j] = 0;
if (j <= k)
sortknum[j] = j;
}
for (i = 1; i <= n; ++i)
{
for (j = 1; j <= m; ++j)
{
cin>>tmp;
satisf[j] += tmp;
}
}
}
{
for (j = 1; j <= m; ++j)
{
cin>>tmp;
satisf[j] += tmp;
}
}
}
void sortKbyValue()
{
int i, j;
// 对k个logo排序
for (i = 1; i < k; ++i)
{
for (j = i+1; j <= k; ++j)
{
if (satisf[sortknum[i]] < satisf[sortknum[j]])
swap(sortknum[i], sortknum[j]);
}
}
}
{
int i, j;
// 对k个logo排序
for (i = 1; i < k; ++i)
{
for (j = i+1; j <= k; ++j)
{
if (satisf[sortknum[i]] < satisf[sortknum[j]])
swap(sortknum[i], sortknum[j]);
}
}
}
void sortKbyNo()
{
int i, j;
{
int i, j;
for (i = 1; i < k; ++i)
{
for (j = i+1; j <= k; ++j)
{
if (sortknum[i] < sortknum[j])
swap(sortknum[i], sortknum[j]);
}
}
}
{
for (j = i+1; j <= k; ++j)
{
if (sortknum[i] < sortknum[j])
swap(sortknum[i], sortknum[j]);
}
}
}
void exchange()
{
int i, j;
for (j = k+1; j <= m; ++j)
{
if (satisf[j] <= satisf[sortknum[k]])
continue;
i = k;
while (i > 0 && satisf[j] > satisf[sortknum[--i]])
{
sortknum[i+1] = sortknum[i];
}
sortknum[i+1] = j;
}
}
{
int i, j;
for (j = k+1; j <= m; ++j)
{
if (satisf[j] <= satisf[sortknum[k]])
continue;
i = k;
while (i > 0 && satisf[j] > satisf[sortknum[--i]])
{
sortknum[i+1] = sortknum[i];
}
sortknum[i+1] = j;
}
}
void printresult()
{
int i;
for (i = 1; i < k; ++i)
{
cout << sortknum[i] << " ";
}
cout << sortknum[k] << endl;
}
{
int i;
for (i = 1; i < k; ++i)
{
cout << sortknum[i] << " ";
}
cout << sortknum[k] << endl;
}
void solve()
{
init();
sortKbyValue();
exchange();
sortKbyNo();
printresult();
}
{
init();
sortKbyValue();
exchange();
sortKbyNo();
printresult();
}
int main(int argc, char* argv[])
{
while (cin>>n>>m>>k)
{
solve();
}
return 1;
}
{
while (cin>>n>>m>>k)
{
solve();
}
return 1;
}