编译原理-翻译布尔表达式

6 篇文章 0 订阅
0x01 题目描述
Input
 多组输入,每组输入为一行字符串,例如: a < b or c < d and e < f
每个符号都用空格间隔
Output
 假链跳到0,真链跳到1,表达式序号从100开始排。
Example Input

1
a < b or c < d and e < f

Example Output

100(j<,a,b,1)
101(j,_,_,102)
102(j<,c,d,104)
103(j,_,_,0)
104(j<,e,f,100)
105(j,_,_,103)

0x02 代码
#include<bits/stdc++.h>

using namespace std;
string str;
int jump,tmp;
vector<string>tt;

int main()
{
    int n;
    scanf("%d\n",&n);
    while(n--)
    {
        getline(cin,str);
        str += " end";
        jump = 1;tmp = 0;
        string s;
        stringstream ss(str);
        int id = 100;
        while(ss >> s)
        {
            if(s == "or")
            {
                printf("%d(j%s,%s,%s,%d)\n",id,tt[1].c_str(),tt[0].c_str(),tt[2].c_str(),jump);
                jump = id++;
                printf("%d(j,_,_,%d)\n",id,id+1);
                id ++;
                tt.clear();
            }
            else if(s == "and")
            {
                printf("%d(j%s,%s,%s,%d)\n",id,tt[1].c_str(),tt[0].c_str(),tt[2].c_str(),id+2);
                id ++;
                printf("%d(j,_,_,%d)\n",id,tmp);
                tmp = id++;
                tt.clear();
            }
            else if(s == "end")
            {
                printf("%d(j%s,%s,%s,%d)\n",id,tt[1].c_str(),tt[0].c_str(),tt[2].c_str(),jump);
                id ++;
                printf("%d(j,_,_,%d)\n",id,tmp);
                tt.clear();
            }
            else
                tt.push_back(s);
        }
    }
    return 0;
}
  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

StriveBen

写字不易,给点动力吧

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值