Integer Inquiry 大数加法模板

Integer Inquiry
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases! 

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks. 

The output format consists of N output blocks. There is a blank line between output blocks. 

Sample Input

1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
 
    
只是一个简单的大数加法,直接套用模板就行,关键的地方时注意输入输出格式
 
    
AC代码:
 
    
#include<cstdio>
#include<cstring>   
#include<algorithm>
#include<iostream>
#include<string>
#define maxn 500
using namespace std;


//大数加法模板 
string add(string s1, string s2) {
	if(s1.length() < s2.length()) {  //确保s1的位数永远大于等于s2的位数 
		string temp = s1;
		s1 = s2;
		s2 = temp;
	}
	int i, j;
	for(i=s1.length()-1, j=s2.length()-1; i>=0; --i, --j) {
		s1[i] = char(s1[i] + (j>=0? s2[j]-'0': 0));   //处理了s1,s2位数不同的情况和相同的情况 
		if(s1[i] - '0' >= 10) {   //当出现进位的时候 
			s1[i] = char((s1[i] - '0')%10 + '0');
			if(i)  ++s1[i-1];
			else  s1 = '1' + s1;  //解决当加到最高位有进位的时候 
		}
	}
	return s1;
}


int main() {
	int n;
	string a, b ,c;
	cin>>n;
	while(n--) {
		b = "0";
		while(cin>>a && a[0]!='0') {
			b = add(a,b);
		}
		cout<<b<<endl;
		if(n>0)  cout<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值