POJ-5353-Fence Repair(哈夫曼问题->贪心(一种解法两种做法))



Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 40578 Accepted: 13273

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer   N, the number of planks  
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make   N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.  
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:给一块长木板,现要将其锯成n段,共需锯n-1次,每次锯的代价为所锯木板的长度,求最小总代价。


题解:

利用Huffman思想,要使总费用最小,那么每次只选取最小长度的两块木板相加,再把这些“和”累加到总费用中即可

本题虽然利用了Huffman思想,但是直接用HuffmanTree做会超时,可以用优先队列做

做法一:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<limits.h>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<string>
#include<math.h>
#include<map>
using namespace std;
#define inf 1e18
#define maxn 20005
long long a[maxn];
long long n;
long long ans;
void Swap(int a,int b)
{
	int temp;
	temp=a;a=b;b=temp;
}
void solve()
{
	ans=0;
	while(n>1)//直到计算到木板为1块时为止
	{
		//求出最短的板x和次短的板y
		int x=0,y=1;
		if(a[x]>a[y])
		   Swap(x,y);
		for(int i=2;i<n;i++)
		{
			if(a[i]<a[x])
			{
				y=x;
				x=i;
			}
			if(a[i]<=a[y])
			  y=i;
		 }
		 long long temp=a[x];//保存最小值 
		 a[x]=inf;
		for(int i=0;i<n;i++)//找寻次小值 
		{
			if(a[i]<a[y])
			y=i;
		}
		//将两板结合
		a[x]=temp; 
		long long t=a[x]+a[y];
		ans+=t;
		if(x==n-1)
		 Swap(x,y); 
		a[x]=t;
		a[y]=a[n-1];
		n--;
    }
    printf("%lld\n",ans);
}
int  main()
{
	int i,j;
	while(scanf("%lld",&n)!=EOF)
	{
		memset(a,0,sizeof(a)); 
		for(i=0;i<n;i++)
		 scanf("%lld",&a[i]);
	     solve();
	}
}

做法二:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<limits.h>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<string>
#include<math.h>
#include<map>
using namespace std;
#define maxn 20005
priority_queue<int,vector<int>,greater<int> >q;
int a[maxn];
int  main()
{
	int i,j,n,x,y;
	long long ans=0;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		q.push(a[i]);
	}
	while(q.size()>1)
	{
		x=q.top();
		q.pop();
		y=q.top();
		q.pop();
		int t=x+y;
		ans+=t;
		q.push(t);
	}
	printf("%lld\n",ans);
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值