POJ 2689 Prime Distance(区间素数筛)

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19574 Accepted: 5257

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


题意:给你一个区间,让你找出两对相邻素数,一对使得距离最小,一对使得距离最大。

如果相同,输出数值小的呢一对。

题解:因为区间很大,我们无法一一暴力找素数,但是我们可以找出区间中的所有合数呀,这样剩下的

不就是素数了嘛,没错,这就是素数筛了,我们知道一个数的质因数一定小于sqrt(自己),因此我们暴力

找出sqrt(2147483647)以内(50000左右)的所有质数,然后在区间中暴力找合数即可。。。这题有个坑点

就是L可以为1,所以稍稍处理一下就OK了。

#include<set>      
#include<map>         
#include<stack>                
#include<queue>                
#include<vector>        
#include<string>     
#include<time.h>    
#include<math.h>                
#include<stdio.h>                
#include<iostream>                
#include<string.h>                
#include<stdlib.h>        
#include<algorithm>       
#include<functional>        
using namespace std;                
#define ll long long           
#define lowbit(x) (x&-x)                
#define inf 2147483647             
#define mod 998244353          
#define maxn  1000005    
#define eps 1e-9 
double mins[maxn];
ll a[maxn]={1,1},b[maxn],c[maxn],d[maxn];
int main(void)
{
	ll l,u,i,j,tmp,d1,d2,x,y,xx,yy,cnt=0,p;
	for(i=2;i<=maxn;i++)
	{
		if(a[i])
			continue;
		b[++cnt]=i;
		for(j=i*i;j<=maxn;j+=i)
			a[j]=1;
	}
	while(scanf("%lld%lld",&l,&u)!=EOF)
	{
		if(l==1)l=2;
		for(i=l;i<=u;i++)
			d[i-l]=i,c[i-l]=0;
		d1=1000000000;d2=0;p=0;
		for(i=1;b[i]*b[i]<=u && i<=cnt;i++)
		{
			tmp=l-l%b[i];
			if(tmp<l)tmp+=b[i];
			for(j=tmp;j<=u;j+=b[i])
			{
				while(d[j-l]%b[i]==0)
					d[j-l]/=b[i],c[j-l]++;
			}
		} 
		for(i=l;i<=u;i++)
		{
			if(d[i-l]>1)
				c[i-l]++;   
		}
		for(i=l;i<=u;i++)
			if(c[i-l]<=1)            
			{
				if(p>0)
				{
					if(d1>i-p)
						d1=i-p,x=p,y=i;
					if(d2<i-p)
						d2=i-p,xx=p,yy=i;
				}
				p=i;
			}
		if(d1-d2>1000000)
			printf("There are no adjacent primes.\n");
		else
			printf("%lld,%lld are closest, %lld,%lld are most distant.\n",x,y,xx,yy);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值