acdream 1234-Two Cylinders(辛普森积分)

Two Cylinders

Special Judge  Time Limit: 2000/1000MS (Java/Others)  Memory Limit: 128000/64000KB (Java/Others)
Problem Description

      In this problem your task is very simple.

      Consider two infinite cylinders in three-dimensional space, of radii R1 and R2 respectively, located in such a way that their axes intersect and are perpendicular.

      Your task is to find the volume of their intersection.

Input
      Input file contains two real numbers R 1 and R 2 (1 <= R 1,R 2 <= 100).
Output
      Output the volume of the intersection of the cylinders. Your answer must be accurate up to 10 -4.
Sample Input
1 1
Sample Output
5.3333

Source

题意:给你两个半径不同的圆柱体,计算垂直相交的体积

题解:当半径相同时,大一高数中学过,相交的体积为:16/3*R^3

当半径不相同时:



这里我们采用辛普森积分来进行积分(否则会越积越复杂)

                              

#include <math.h>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const double eps = 1e-10;
const double PI = acos(-1.0);
double r1,r2;
double f(double x)
{
	return sqrt((r1*r1-x*x)*(r2*r2-x*x)); 
}
double simpson(double a,double b)
{
	double c=a+(b-a)/2;
	return (f(a)+4*f(c)+f(b))*(b-a)/6; 
}
double asr(double a,double b) ///迭代求解数值积分  
{  
    double mid=(a+b)/2.0;  
    double res=simpson(a,b);  
    if(fabs(res-simpson(a,mid)-simpson(mid,b))<eps)  
    {  
        return res;  
    }  
    else return asr(a,mid)+asr(mid,b);  
}
int main(void)
{
	while(scanf("%lf%lf",&r1,&r2)!=EOF)
	{
		if(r1==r2)
			printf("%.4lf\n",16.0/3*r1*r1*r1);
		else
		{
			if(r1>r2)
				swap(r1,r2);
			printf("%.4lf\n",8.0*asr(0,r1));
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的公寓报修管理系统,源码+数据库+毕业论文+视频演示 现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本公寓报修管理系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此公寓报修管理系统利用当下成熟完善的Spring Boot框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。公寓报修管理系统有管理员,住户,维修人员。管理员可以管理住户信息和维修人员信息,可以审核维修人员的请假信息,住户可以申请维修,可以对维修结果评价,维修人员负责住户提交的维修信息,也可以请假。公寓报修管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 关键词:公寓报修管理系统;Spring Boot框架;MySQL;自动化;VUE
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值