HDU 2298-Toxophily (三分+二分)

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2443    Accepted Submission(s): 1351


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit.
 

Sample Input
  
  
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output
  
  
1.561582 -1 -1
 

Source

题意:你站在(0,0)点,然后一个东西在点(x,y),子弹速度为V,问你枪口与x轴最小夹角为多少时可以射到该东西。
题解:对于该题,我们可以列出以下物理方程:
(1)y=vy*t-1/2*t*t*g.(g为加速度)
(2)vy=v*sin(a) (a为所求夹角)
(3)vx=v*cos(a)
(4)t=x/vx;
根据以上方程我们可以求出子弹能到达的最大高度(我们可以三分求解),以及所对应的夹角。
然后我们分情况讨论,最大高度假如小于物体的高度,呢不管怎么改变角度都无法射到
若最大高度大于物体高度,则可以二分仰角,来求得最小值。
#include<math.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define pi acos(-1.0)
#define eps 1e-10
double x,y,v,hx,gx;
double cal(double a)
{
	double vx=v*cos(a);
	double vy=v*sin(a);
	double t=x/vx;
	double h=vy*t-9.8*t*t/2.0;
	return h;
}
double work()
{
	double l=0,r=pi/2.0,m1,m2;
	while(r-l>eps)
	{
		m1=(l+r)/2.0;
		m2=(m1+r)/2.0;
		if(cal(m1)-cal(m2)>0)
			r=m2;
		else
			l=m1;
	}
	return l;
}
double find(double x)
{
	double l=0,r=x,mid;
	while(r-l>eps)
	{
		mid=(l+r)/2.0;
		if(cal(mid)<y)
			l=mid;
		else
			r=mid;
	}
	return l;
}
int main(void)
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf%lf%lf",&x,&y,&v);
		gx=work();hx=cal(gx);
		if(y-hx>eps)
			printf("-1\n");
		else if(fabs(hx-y)<=eps)
			printf("%.6f\n",gx);
		else
		{
			double ans=find(gx);
			printf("%.6f\n",ans);
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值