1035 Password

该程序旨在处理PAT比赛中的随机密码问题,将容易混淆的数字和字母进行替换,如1替换成@,0替换成%,小写l替换成大写L,大写O替换成小写o。程序读入用户账户和密码,检查并修改可能引起混淆的密码,然后按照原顺序输出修改后的账户信息。
摘要由CSDN通过智能技术生成

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include <iostream>
using namespace std;

string replace(string str){
    string res;
    for(auto i : str){
        if(i=='1') res += '@';
        else if(i=='0') res += '%';
        else if(i=='l') res += 'L';
        else if(i=='O') res += 'o';
        else res += i;
    }
    return res;
}
int main(){
    int n;
    cin >> n;
    int m = 0;
    string users[1010];
    string passwords[1010];
    for(int i = 0 ; i < n ; i++){
        string user,password;
        cin >> user >> password;
        string rep = replace(password);
        if(password!=rep){
            users[m] = user;
            passwords[m] = rep;
            m++;
        }
    }
    if(m>0) {
        cout << m << endl;
        for(int i = 0;i < m; i++){
            cout<< users[i] << ' ' <<passwords[i] << endl;
        }
    }else{
        if(n==1) cout << "There is 1 account and no account is modified";
        else printf("There are %d accounts and no account is modified",n);
    }
}

总结

1. 模拟题,按题目意思来即可

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值