hdoj 1004 Let the Balloon Rise 解题报告

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

基本思想是:定义一个大于1000的字符串数组a[1005],a[i](元素为一个字符串)代表一个气球的颜色,找出相同颜色数量最多的数量(求最大值的思想)和其在数组中的位置dir,输出a[dir]即是相同颜色最多的气球颜色。

第一遍的时候是WA 代码如下:

#include <iostream>
#include <string>
using namespace std;
int main(){
    string a[1005];
    int n;
    while (cin>>n&&n)
    {    int max=0 ,dir=0,sum=0;
        for (int i = 0; i < n; i++)  //输入气球的颜色
        {
            cin>>a[i];
        }
        for (int i = 0; i < n; i++)  /*对每一个气球颜色求与他相同颜色的个数*/
        {
            for (int j = 0; j < n; j++)
            {
                if(a[i]==a[j])
                    sum++;
            }

            if (sum>max)
            {
                max=sum;
                dir=i;
                sum=0;  //第一次出错的地方
            }

        }
        cout<<a[dir]<<endl;
    }
    return 0;
}

虽然上面的代码可以符合测试的例子,但是确实错误的答案,其中是因为一个小细节给弄错了,sum=0的位置放错了,应该对每个颜色求完它的相同颜色的数量后都需要,sum置为0。

第二遍正确的代码如下:

#include <iostream>
#include <string>
using namespace std;
int main(){
    string a[1005];
    int n;
    while (cin>>n&&n)
    {    int max=0 ,dir=0,sum=0;
        for (int i = 0; i < n; i++)
        {
            cin>>a[i];
        }
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < n; j++)
            {
                if(a[i]==a[j])
                    sum++;
            }

            if (sum>max)
            {
                max=sum;
                dir=i;
            }
            sum=0;  //正确的位置
        }
        cout<<a[dir]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值