hdoj.1002 A + B Problem II【大数问题】 20140730

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209692    Accepted Submission(s): 40335


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
#include<stdio.h>
#include<string.h>
int main()
{
    char s1[1010],s2[1010];
    int n,i,j,k;
    int a[1010],b[1010],c[1010];
    scanf("%d",&n);
    for(i=1;i<=n;i++){
        scanf("%s %s",s1,s2);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        int l1=strlen(s1);
        for(j=l1-1,k=0;j>=0;j--) 
            a[k++]=s1[j]-'0';
        int l2=strlen(s2);
        for(j=l2-1,k=0;j>=0;j--)
            b[k++]=s2[j]-'0';
        int max=l2;
        if(l1>l2) max=l1;
        memset(c,0,sizeof(c));
        for(j=0;j<max;j++){
            c[j]=c[j]+a[j]+b[j];
            if(c[j]>=10){
                c[j]-=10;
                c[j+1]++;
            }
        }
        if(c[max]) max++;
        printf("Case %d:\n",i);
        for(j=0;j<l1;j++) printf("%c",s1[j]);
        printf(" + ");
        for(j=0;j<l2;j++) printf("%c",s2[j]);
        printf(" = ");
        for(j=max-1;j>=0;j--) printf("%d",c[j]);
        printf("\n");
        if(i!=n) printf("\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值