Moving Tables

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

 

标准输入

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

 

标准输出

The output should contain the minimum time in minutes to complete the moving, one per line.

 

样例输入

 

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

 

样例输出

 

10

20

30

题意描述:移动一张桌子无论距离多长都是需要10分钟,两个房间组成一个道路,当存在公共道路时不能同时移动,求把桌子移动玩需要多长时间。

用数组表示200条道路,每经过一次进行一次标记,最后求出标记次数最多的道路乘10

 

#include<stdio.h>
int main()
{
	int t,n,i,j,a[500],b[500],c[300],max,min,h;
	scanf("%d",&t);
	while(t--)
	{
		max=0;
		h=0;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i],&b[i]);
		for(i=1;i<=205;i++)
			c[i]=0;
		for(i=1;i<=n;i++)
		{
			if(b[i]>a[i])
			{
				for(j=a[i];j<=b[i];j=j+2)
					c[(j+1)/2]++;
				max=b[i];
				min=a[i];
			}
			if(a[i]>=b[i])
			{
				for(j=b[i];j<=a[i];j=j+2)
					c[(j+1)/2]++;
				max=a[i];
				min=b[i];
			}                        \\a[]和b[]的大小不一定。
			if(min%2==0&&max%2!=0)
				c[(max+1)/2]++;	\\这里有一种特殊情况。
		}	
		for(i=1;i<=200;i++)
		{
			if(c[i]>h)
				h=c[i];
		}
		printf("%d\n",h*10);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值