HDU - 2389 Rain on your Parade(Hopcroft Karp算法)

题目:https://acm.hdu.edu.cn/showproblem.php?pid=2389

                                     Rain on your Parade

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 655350/165535 K (Java/Others)
Total Submission(s): 8368 Accepted Submission(s): 2587

Problem Description
You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
Can you help your guests so that as many as possible find an umbrella before it starts to pour?

Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however.

Input
The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
The absolute value of all coordinates is less than 10000.

Output
For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.

Sample Input
2
1
2
1 0 3
3 0 3
2
4 0
6 0
1
2
1 1 2
3 3 2
2
2 2
4 4

Sample Output
Scenario #1:
2

Scenario #2:
2

#include <iostream>
#include <math.h>
#include <string.h>
#include <queue>
using namespace std;

const int N = 3010,M = 3010,E = 9000010;
const int inf = 0x3f3f3f3f;

struct guest{  //客人 
	int x, y,v;
}a[N];
struct umbrella{ //雨伞 
	int x, y;
}b[M];

struct edge{  //边 
	int next,to;
}edges[E];

int head[N];
int cnt;

bool vis[N];  
int n_dist[N],n_match[N];  //n_dist记录层次,n_match记录y部分匹配的x点 
int matched[N]; // 记录x点是否匹配,0未匹配,1匹配 
int nx,ny,time; //客人数,雨伞数,下雨前的时间 

void add(int u,int v){  //添边 
	edges[++cnt].next = head[u];
	edges[cnt].to = v;
	head[u] = cnt;
}

double dist(int x1,int y1,int x2,int y2){ //求两点距离 
	return sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
}

void init(){ //初始化 
	
	cnt = 0;
	memset(head,0,sizeof(head));
	memset(n_match,0,sizeof(n_match));
	memset(matched,0,sizeof(matched));
}

bool bfs(){  //求层次 
	
	queue<int> q;
	
	for(int i = 1;i<=nx;i++){
		if(matched[i])
			n_dist[i] = inf;
		else
			n_dist[i] = 0,q.push(i);
	}
	n_dist[0] = inf;
	
	while(!q.empty()){
		
		int u = q.front();
		q.pop();
		
		if(n_dist[u] >= n_dist[0]) break;
		
		for(int i = head[u];i;i = edges[i].next){
			int v = edges[i].to;
			
			if(n_dist[n_match[v]] == inf){
				n_dist[n_match[v]] = n_dist[u]+1;
				if(n_match[v]!=0) q.push(n_match[v]);
			}
		}
	}
	return n_dist[0]!=inf;
}

bool dfs(int u){  
	
	if(u == 0) return true;
	
	for(int i = head[u];i;i = edges[i].next){
		
		int v = edges[i].to;
		
		if(!vis[v] && n_dist[n_match[v]] == n_dist[u]+1 && dfs(n_match[v])){
			vis[v] = true;
			matched[u] = 1;
			n_match[v] = u;
			return true;
		}
	}
	return false;
}

void MaxMatch(){  //求最大匹配 
	
	int ans = 0;
	
	while(bfs()){
		
		memset(vis,false,sizeof(vis));
		
		for(int i = 1;i<=nx;i++){
			if(matched[i] == 0 && dfs(i)) ans++; 
		}
	}
	cout << ans << "\n\n";
}

void read(){  //输入数据 
	
	init();
	cin >> time >> nx;
	
	for(int i = 1;i<=nx;i++)
		cin >> a[i].x >> a[i].y >> a[i].v;
	
	cin >> ny;
	for(int i = 1;i<=ny;i++)
		cin >> b[i].x >> b[i].y;
	
	for(int i = 1;i<=nx;i++)
		for(int j = 1;j<=ny;j++){
			
			double limit = a[i].v * time;
			double dis = dist(a[i].x,a[i].y,b[j].x,b[j].y);  
			
			if(dis <= limit) add(i,j);  //根据距离构造边 
		}
}

int main(){
	
	std:ios_base::sync_with_stdio(false);
	
	int t;
	cin >> t;
	
	int id = 1;
	while(t--){
		
		read();
		
		cout << "Scenario #" << id++ << ":" << endl;
		MaxMatch();
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值