hdu 2025 查找最大元素

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2025

查找最大元素

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32474    Accepted Submission(s): 17937


Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
 

Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
 

Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
 

Sample Input
  
  
abcdefgfedcba xxxxx
 

Sample Output
  
  
abcdefg(max)fedcba x(max)x(max)x(max)x(max)x(max)
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1008  1161  1013  1043  1073 
 

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN = 110;


int main()
{
    char str[MAXN], iMax;
    int i;
    while(~scanf("%s", str))
    {
        iMax = str[0];
        int iLen = strlen(str);
        for(i = 0; i < iLen; ++i)
        {
            if(str[i] > iMax)
                iMax = str[i];
        }
        for(i = 0; i < iLen; ++i)
        {
            printf("%c", str[i]);
            if(str[i] == iMax)
                printf("(max)");
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值