joj1349

 1349: Oil Deposits


Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 580 285 Standard
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.


A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input


The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise   and  . Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output


For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input


1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output


0
1
2
2





这道题目我调试了很久,不是因为这个题比较难,这个是一个很基础的深度优先搜索的题目,在我进行判断的时候如for(int i=u+1,j=v-1;i<=m&&j>0;i++,j--)将其中的&&换做了,而且我现在才知道“,”的意思是||而不是&&!!!!!

#include<cstdio>

#include<cstring>
using namespace std;
char map[103][103];
int visited[103][103];
int m,n;
void dfs(int u,int v)
{
visited[u][v]=1;
//向上
for(int i=u-1;i>0;i--)
{
if(map[i][v]=='*')break;
if(!visited[i][v]&&map[i][v]=='@')
{
dfs(i,v);
}
}
//向下
for(int i=u+1;i<=m;i++)
{
if(map[i][v]=='*')break;
if(!visited[i][v]&&map[i][v]=='@')
dfs(i,v);
}
//向右
for(int i=v+1;i<=n;i++)
{
if(map[u][i]=='*')break;
if(!visited[u][i]&&map[u][i]=='@')
dfs(u,i);
}
//向左
for(int i=v-1;i>0;i--)
{
if(map[u][i]=='*')break;
if(!visited[u][i]&&map[u][i]=='@')
dfs(u,i);
}
//左上
for(int i=u-1,j=v-1;i>0&&j>0;i--,j--)
{
if(map[i][j]=='*')break;
if(!visited[i][j]&&map[i][j]=='@')
dfs(i,j);
}
//左下
for(int i=u+1,j=v-1;i<=m&&j>0;i++,j--)
{
if(map[i][j]=='*')break;
if(!visited[i][j]&&map[i][j]=='@')
dfs(i,j);
}
//右上
for(int i=u-1,j=v+1;i>0&&j<=n;i--,j++)
{
if(map[i][j]=='*')break;
if(!visited[i][j]&&map[i][j]=='@')
dfs(i,j);
}
//右下
for(int i=u+1,j=v+1;i<=m&&j<=n;i++,j++)
{
if(map[i][j]=='*')break;
if(!visited[i][j]&&map[i][j]=='@')
dfs(i,j);
}
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(scanf("%d%d",&m,&n),m)
{
memset(visited,0,sizeof(visited));
for(int i=1;i<=m;i++)
scanf("%s",map[i]+1);
int sum=0;
for(int i=1;i<=m;i++)
{
for(int j=1;j<=n;j++)
{
if(!visited[i][j]&&map[i][j]=='@')
{
dfs(i,j);
sum++;
}
}
}
printf("%d\n",sum);
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值