joj2699

 2699: 16 and 18


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
1s 65536K 285 65 Standard

16 and 18 are good friends. They are playing a game.

The rules are as following:

(1) 16 and 18 will give numbers in turn. At first 16, then 18, and then 16...
(2) If the previous one give a number A, the number the next one gives, namely B, must satisfy that
1 <= B - A <= k.
(3) Who first gives the number larger than or equal to N will lose the game.
(4) The game always starts with 16, and he can only give a number from [1, k] in the first round.
(5) Suppose that both of them will try their best to win.

Input

In each line, there will be two integers N (0 < N <= 100, 000, 000) and k (0 < k <= 100). Input terminates when N = k = 0

Output

For each case, print the winner's name in each line.

Sample Input

1 1
30 3
10 2
0 0

Sample Output

18
16
18

Problem Source: homeboy





博弈问题详细情况可以看我转载的博弈问题总结



#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k),n&&k)
    {
        if((n-1)%(k+1)==0)cout<<18<<endl;
        else cout<<16<<endl;
    }
    return 0;
}



This problem is used for contest: 168  190 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值