joj1966

 1966: Super Market III


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
1s 10240K 177 75 Standard

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

这个问题是并查集的应用,本来做这个题目是为了检验书上的代码是不是正确的。结果按书上的思是错误的不知道是我理解错了还是书上的代码错了。只能自己按自己的思路想了一个方法。。不过我觉得老师说的最有权威的一句话就是“你的想法可能是正确的但是考试要按照我的的来!!!”
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
struct NODE
{
    int profile;
    int deadline;
};
int f[10001];
NODE node[10001];
bool cmp(const NODE &n1,const NODE&n2)
{
    return n1.profile>n2.profile;
}
int find(int u)
{
    return f[u]=(f[u]==u?u:find(f[u]));
}
int cal(int n)
{
    int k=0;
    for(int i=0;i<=n;i++)f[i]=i;
    for(int i=1;i<=n;i++)
    {
        int j=find(min(n,node[i].deadline));
        if(j!=0)
        {
            int u=find(j-1);
            k+=node[i].profile;
            f[j]=u;
        }
    }
    return k;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&node[i].profile,&node[i].deadline);
        }
        sort(node+1,node+n+1,cmp);
        cout<<cal(n)<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值