GO 运行提示build command-line-arguments: cannot loadXXXXX问题,go mod 加载问题

go 再1.11版本后增加了go mod功能,程序运行时会自动加载程序所需要的的包
使用Go的包管理方式,依赖的第三方包被下载到了https://goproxy.cn路径下面
可以在go.mod中指定版本

由于被墙的原因,go mod会遇到访问不到加载不了依赖,
我们就需要在环境变量中设置一下

GOPROXY:https://goproxy.cn
https://goproxy.cn
重启一下ide编辑器,程序便可以顺利加载运行

发布了6 篇原创文章 · 获赞 0 · 访问量 104
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览