codeup

题目描述
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d

e l

l r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出
For each test case, print the input string in the shape of U as specified in the description.

样例输入 Copy
helloworld!
样例输出 Copy
h !
e d
l l
lowor

#include <stdio.h>
#include <string.h>



int main()
{
    int n, n1, n2, n3;
    char str[80];

    while(scanf("%s", str) != EOF)
    {
        n = strlen(str);
        n1 = n3 = (n + 2)/3;
        n2 = (n + 2)/3 + (n + 2)%3;

        char prtstr[n1][n2];

        int i, j;

        for(i = 0; i < n1; i++)
        {
            prtstr[i][0] = str[i];

        }

        i--;// i = n1 -1
        for(j = 0; j < n2; j++)
        {

            prtstr[n1 - 1][j] = str[i];

            i++;
        }

        i--;
        for(int k = 0; k < n3; k++)
        {

            prtstr[n3 - 1 - k][n2 - 1] = str[i];

            i++;
        }

        for(int l = 0; l < n1; l++)
        {
            for(int m = 0; m < n2; m++)
            {
                if((l == n1 - 1) || (m == 0) || (m == n2 - 1)) printf("%c", prtstr[l][m]);
                else printf(" ");

            }
            printf("\n");
        }
    }


    return 0;
}

注意:for循环中i++,j++ 的次数分别是n1 ;所以循环完要 i–,调整计数位置使之为n1 - 1.

题目来源:codeup100000577&pid=1。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值