Command "/usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-f8m_zq/statsmod

pip安装工具时报错提醒:Command "/usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-f8m_zq/statsmod

原因是安装工具包时需要抓取网页因而要处理 https,而处理 https 又依赖加解密算法(即 cryptography 包),而 cryptography 又依赖傅立叶变换的算法以及相应的编译环境。Ubuntu 16.04 默认没有安装 libffi-dev 和 libssl-dev,gcc 也不一定安装,而 目标安装包又没有将相关软件包记到依赖列表里,因此需要先手动安装:

sudo apt-get install libssl-dev libffi-dev python-dev build-essential libxml2-dev libxslt1-dev

阅读更多
上一篇virtualenv和virtualenvwrapper
下一篇ssh 验证失败次数过多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭