迷宫问题

题目:
定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

代码:

#include <stdio.h>
#include <string.h>
struct note
{
	int x;
	int y;
	int f;
	int s;
};

int main()
{
	struct note que[50];
	int a[8][8],book[8][8];
	int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
	int i,j,k,flag,x,y,tx,ty,head,tail;
	memset(a,0,sizeof(a));
	memset(book,0,sizeof(book));
	for(i=0;i<5;i++)
		for(j=0;j<5;j++)
			scanf("%d",&a[i][j]);
	head=0;
	tail=0;
	que[tail].x=0;
	que[tail].y=0;
	que[tail].f=0;
	que[tail].s=0;
	tail++;
	book[0][0]=1;
	flag=0;
	while(head<tail)
	{
		for(k=0;k<=3;k++)
		{
			tx=que[head].x+next[k][0];
			ty=que[head].y+next[k][1];
			if(tx<0||tx>4||ty<0||ty>4)
				continue;
			if(a[tx][ty]==0&&book[tx][ty]==0)
			{
				book[tx][ty]=1;
				que[tail].x=tx;
				que[tail].y=ty;
				que[tail].f=head;
				que[tail].s=que[head].s+1;
				tail++;
			}
			if(tx==4&&ty==4)
			{
				flag=1;
				break;
			}
		}
		if(flag==1)
			break;
		head++;
	}
	int f[100][2];
	int s=tail-1;
	k=0;
	memset(f,0,sizeof(f));
	while(s!=0){
		f[k][0]=que[s].x;
		f[k][1]=que[s].y;
		k++;
		s=que[s].f;
	}
	for(i=k;i>=0;i--)
		printf("(%d, %d)\n",f[i][0],f[i][1]);
	return 0;
}
解题思路:用的是广搜。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值