Truck History

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

 

题意:给出n个长度为7的字符串,每个字符串代表一个车,定义车的距离是两个字符串间不同字母的个数,题目要求的数不同的车的距离的最小值,即所求的就是最小生成树。

解题思路:套prim模板。只是注意开始先求出距离(即相同位置的不同字母的个数)。

代码:

#include <stdio.h>
#include <string.h>
#define inf 99999999
char s[2010][2010];
int e[2010][2010];
int book[2010],dis[2010];

int main()
{
	int i,j,k,n,min,count,sum,num;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		count=0;sum=0;num=0;
		memset(e,0,sizeof(e));
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			scanf("%s",s[i]);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				count=0;
				for(k=0;k<7;k++)
				{
					if(s[i][k]!=s[j][k]) //统计不同的字符数 
						count++;
				}
				e[i][j]=e[j][i]=count; 
			}
		}
		for(i=1;i<=n;i++)
			dis[i]=e[1][i];
		book[1]=1;
		num++;
		while(num<n)
		{
			min=inf;
			for(i=1;i<=n;i++)
			{
				if(book[i]==0&&dis[i]<min)
				{
					min=dis[i];
					j=i;
				}
			}
			if(min==inf)
				break;
			book[j]=1;
			num++;
			sum+=dis[j];
			for(k=1;k<=n;k++)
			{
				if(book[k]==0&&dis[k]>e[j][k])
					dis[k]=e[j][k];
			}
		}
		printf("The highest possible quality is 1/%d.\n",sum);	
	}
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值