find the nth digit

 

Time Limit : 1000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 9 Accepted Submission(s) : 3

Font: Times New Roman | Verdana | Georgia

 Font Size: ← →

Problem Description

假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

Input

输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。 

Output

对于每个N,输出S中第N个对应的数字.
 

Sample Input

6
1
2
3
4
5
10

 Sample Output

1
1
2
1
2
4
分析:这道题如果纯模拟可能会超时,我们可以找到规律(n+1)*(n)/2,所以要找到N值是关键。开始我做的是用循环找N,后来发现会超时。
仔细想想发现可以街一元二次方程求出N。

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;

int main()
{
	int k;
	double  x,n;
	int y;

	scanf("%d", &k);
	while(k--)
	{
		scanf("%lf", &n);

		x = int((sqrt(1.0 + 8.0*n) -1)/2);
		y = int(n-x*(x+1)/2);

		if(y == 0)
		{	
			if(int(x)%9 == 0)
				printf("9\n");
			else
				printf("%d\n", int(x)%9);

		}
		else
		{	
			if(y%9 == 0)
				printf("9\n");
			else
				printf("%d\n", y%9);
		}
	}

	return 0;
}

代码:

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值