poj1014 dividing(多重背包+二进制优化)

看到这个题我真是感慨万千,无数tlm,经过二进制优化后,居然来了个pe,原因是当cnt%2==1没有输出一个换行符。看来人品是太好了!

题目:

   有1,2,3,4,5,6六种硬币,输入它们分别得个数,把这些硬币分成两半看是否能实现。

  首先cnt%2==1,肯定是不能平分的。

  用hdu coin那道题目一样,都是用多重背包+二进制转化的思想。具体参照上篇博客。

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

Sample Input

    
    
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0

Sample Output

    
    
Collection #1: Can't be divided. Collection #2: Can be divided.

 

 

代码:


#include<iostream>
using namespace std;
int f[1200005];
int c[10];
int main()
{
    int i,j,k,t=1,cnt,sum,mount;
    while(1)
    {
       cnt=0;
       for(i=1;i<=6;i++)
       {
         scanf("%d",&c[i]);
         cnt+=c[i]*i;
       }
       if(cnt==0) {break;}
       printf("Collection #%d:\n",t++);
       if(cnt%2) {printf("Can't be divided.\n");printf("\n");continue;}
       sum=cnt/2;
       memset(f,0,sizeof(f));
       f[0]=1;
       for(i=1;i<=6;i++)
       {
        mount=c[i];
        for(k=1;k<=mount;k<<=1)
        {
          for(j=cnt;j>=k*i;j--)
             f[j]+=f[j-k*i];
          mount-=k;
        }
        if(mount)
          for(j=cnt;j>=mount*i;j--) f[j]+=f[j-mount*i];
      }
      if(f[sum]) printf("Can be divided.\n");
      else printf("Can't be divided.\n");
      printf("\n");
 }
 return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值