主要是堆的建立,边插入边建立 || 基础实验4-2.5 关于堆的判断 (25分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:
F
T
F
T

注意:这道题是边插入边建立

目前还不会智能一点的文本比对,只会很机械的对比



//用数组的形式存放heap
//the most important is the InsertHeap()


#include<iostream>

using namespace std;
int heap[100];int cnt=0;
void InsertHeap(int x){
    int i,j;
    heap[++cnt]=x;
    i=cnt;
    j=i/2;
    while(j>=1){
        if(heap[j]>heap[i]){
            swap(heap[j],heap[i]);
            i=j;
            j=i/2;
        }else
            break;
    }
}
void JudgeCommend1(int heap[]);

int main(){
    int n,m,x;
    cin>>n>>m;
    for(int i=1;i<=n;i++){
        cin>>x;
        InsertHeap(x);
    }
    
    /*for(int i=1;i<=n;i++){
        cout<<"check001:"<<heap[i]<<"  "; check001:10  check001:23  check001:26  check001:46  check001:24
    }*/
    
    /*下面是传统的人工判断
     if(heap[1]==24){
        cout<<"T"<<endl;
    }else cout<<"F"<<endl;
   int f1=0,f2=0;
    for(int i=1;i<=n;i++){
        if(heap[i]==23) f1=i;
        if(heap[i]==26) f2=i;
        if(f1!=0&&f2!=0){
            if(f1/2==f2/2){
                cout<<"T"<<endl;
            }else cout<<"F"<<endl;
            break;
        }
    }
    int f3=0;
    for(int i=1;i<=n;i++){if(heap[i]==46){f3=i;break;}}
    if(f3==f2/2){
        cout<<"T"<<endl;
    }else cout<<"F"<<endl;
    if(f2/2==1){
        cout<<"T"<<endl;
    }else cout<<"F"<<endl;*/
    return 0;
}



在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值