CCF计算机软件认证题目--出现次数最多的数

问题描述
给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式

输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。

输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。

输出格式
输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入

6

10 1 10 20 30 20

样例输出

10

贴上别人写的短小C++代码:

/****************************************************************************/
/* CCF软件能力认证考试模拟题 —— 出现次数最多的数	皮皮 2014-8-30	*/
/****************************************************************************/
#include <assert.h>
#include <iostream>
#include <map>
using namespace std;

int main(){
	//assert( freopen("CCF\\mostOftenNum.in", "r", stdin) );
	int n, num;
	typedef map<int, int> intIntMap;
	intIntMap numCount;

	cin>>n;
	for(int i = 0; i < n; i++){
		cin>>num;
		numCount[num]++;
	}

	int max_num = INT_MIN, max = -1;
	for(intIntMap::iterator pos = numCount.begin(); pos != numCount.end(); pos++){
		//cout<<pos->first << " : " << pos->second << endl;
		if( pos->second > max || (pos->second == max && pos->first < max_num)){
			max = pos->second;
			max_num = pos->first;
		}
	}
	cout<< max_num << endl;

	//fclose(stdin);
	return 0;
}
贴上我写的C代码:

#include<stdio.h>
#include<memory.h>
#include<stdlib.h>//stdio.h stdlib.h是基本的头文件

int main()
{
	int count;
	int *array = NULL;
	int *array1 = NULL;
	FILE *file = freopen("input.txt", "r", stdin);
	if (!file)
		return 0;

	array = (int *)malloc(1001 * sizeof(int));
	array1 = (int *)malloc(10001 * sizeof(int));

	if (scanf("%d", &count) != EOF)
	{

		memset(array, 0, 1001 * sizeof(int));
		memset(array1, 0, 10001 * sizeof(int));
		for (int i = 0; i < count; i++)
		{
			scanf("%d", array + i);
			*(array1 + *(array + i)) += 1;
		}
		int cishu = -1;
		int value = 10000;
		for (int i = 0; i < count; i++)
		{
			//printf("%d %d\n", *(array1 + *(array + i)), *(array + i));
			//if ( (*(array1 + *(array + i)) >= cishu) && (*(array + i) < value)) 这种写法考虑的情况有问题。
			if ((*(array1 + *(array + i)) > cishu) || ((*(array1 + *(array + i)) == cishu) && (*(array + i) < value)))
			{
				cishu = *(array1 + *(array + i));
				value = *(array + i);
			}
			
		}
		printf("%d", value);

	}
	free(array);
	free(array1);
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值