Wireless Network

http://poj.org/problem?id=2236

Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意:有N台电脑,知道他们的坐标,并且如果两台之间的距离小于d的话,并且这两台都修好了就可以联网,并且可以通过其他电脑连接。简单并差集。

解题思路: 这是一个简单并差集题目。每次修复一台电脑后就将其标记成true,让后遍历一次判断是否有有与其连同的且他们的距离是否满足能修复距离,如果有将其父节点置成同一个。查询时只要查询他们是否有共同的父节点。

复杂度分析:时间复杂度:o(n*x)x为输入的指令条数

#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=10000+5;
int N,d;
char op[10];
int par[maxn],ranks[maxn];
bool vis[maxn];//代表着是否已经修复了电脑,电脑是否正常
struct co {
    int x,y;
} coh[maxn];
void init(int sizes) {
    for(int i=0; i<=sizes; i++) {
        par[i]=i;
        ranks[i]=1;
    }
}
int find(int x) {
    return par[x]==x?x:par[x]=find(par[x]);
}
bool same(int x,int y) {
    return find(x)==find(y);
}
bool judge(int x,int y) {
    return pow((coh[x].x-coh[y].x),2.0)+pow((coh[x].y-coh[y].y),2.0)<=pow(d,2.0);//判断距离是否符合条件
}
void unite(int x,int y) {
    x=find(x);
    y=find(y);
    if(x==y)return ;
    if(ranks[x]>ranks[y]) {
        par[y]=x;
    } else {
        par[x]=y;
        if(ranks[x]==ranks[y])ranks[x]++;
    }
}
int main() {
    int c,e;
    scanf("%d%d",&N,&d);
    init(N);
    memset(vis,false,sizeof(vis));
    for(int i=1; i<=N; i++) {
        scanf("%d%d",&coh[i].x,&coh[i].y);
    }
    while(~scanf("%s",op)) {
        if(op[0]=='O') {
            scanf("%d",&c);
            vis[c]=true;
            for(int i=1; i<=N; i++) {
                if(vis[i]&&judge(c,i)) {//与其他的电脑进行联系的前提是他们是好的,如果不好就连接不上
                    unite(c,i);
                }
            }
        } else {
            scanf("%d%d",&c,&e);
            if(vis[c]&&vis[e]&&same(c,e)) {//是否通信,要看电脑是否已经修复完成
                printf("SUCCESS\n");
            } else printf("FAIL\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值