POJ 2155 Matrix

http://poj.org/problem?id=2155


Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y].

Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.

Output
For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

这是一题简单的二维树状数组。


       题目大意:给你一个N*N的表格,每个格子只有两种状态0或1,初始时都为0。然后有M个操作,Q X Y意思

                         是问你第X行第Y列格子的状态,并输出。C X1 Y1 X2 Y2 表示将以点(X1,Y1)为左上角,以点(X2,Y2)

                         为右下角的矩形内每个格子状态改变一次。

   

      解题思路:这题如果用暴力,毋庸置疑会超时。后来想了好久,思考了一两天,最终用二维树状数组。使用树

                        状数组在这有个技巧,就是我们不需要保留区域格子的状态,只需要记录它被访问了几次就好,最后

                        查找,如果访问为偶数次那么状态为零,否则状态为1.

                        首先我先更新点(X1,Y1)(就是加一),此时我们会多跟新两个长方形的区域,所以这时候要一起更新

             点(X1,Y2+1),(X2,Y1),但是这时候点(X2+1,Y2+1)(N,N)围成的矩形被更新了三次,根据状态跟更新次

             数的奇偶性关系,知点(X2+1,Y2+1)也要更新一次。所以C X1 Y1 X2 Y2 要更新四个点分别为(X1,Y1)

             (X1,Y2+1),(X2,Y1)(X2+1,Y2+1)

 

                        复杂度分析:时间复杂度: O( Q*logn*logn) 。 空间复杂度 :o(n*n)



<span style="font-size:24px;">#include<iostream>
 #include<cstdio>
 #include<cstring>
 #include<algorithm>
 #include<cmath>
 using namespace std;
 const int maxn=1005;
 int va[maxn][maxn];
 int n,m;
 int lowbit(int x)
 {
     return x&(-x);
 }
 void update(int x,int y)
 {
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
           va[i][j] +=1;
 }
 int Sum(int x,int y)
 {
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
          ans+=va[i][j];
    return ans;
 }
 int main()
 {
     int N;
     int x1,y1,x2,y2;
     char op[10];
     scanf("%d",&N);
     while(N--)
     {
        memset(va,0,sizeof(va));
        scanf("%d %d",&n,&m);
        while(m--)
        {
            scanf("%S",op);
            if(op[0]=='C')
            {
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                update(x1,y1);
                update(x1,y2+1);
                update(x2+1,y1);
                update(x2+1,y2+1);
            }
            else
            {
                scanf("%d %d",&x1,&y1);
                printf("%d\n",Sum(x1,y1)%2);
            }
        }
        printf("\n");
     }
     return 0;
 }</span>



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值