bzoj3312: [Usaco2013 Nov]No Change

3312: [Usaco2013 Nov]No Change

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 4   Solved: 4
[ Submit][ Status]

Description

Farmer John is at the market to purchase supplies for his farm. He has in his pocket K coins (1 <= K <= 16), each with value in the range 1..100,000,000. FJ would like to make a sequence of N purchases (1 <= N <= 100,000), where the ith purchase costs c(i) units of money (1 <= c(i) <= 10,000). As he makes this sequence of purchases, he can periodically stop and pay, with a single coin, for all the purchases made since his last payment (of course, the single coin he uses must be large enough to pay for all of these). Unfortunately, the vendors at the market are completely out of change, so whenever FJ uses a coin that is larger than the amount of money he owes, he sadly receives no changes in return! Please compute the maximum amount of money FJ can end up with after making his N purchases in sequence. Output -1 if it is impossible for FJ to make all of his purchases.

Input

Line 1: Two integers, K and N.

* Lines 2..1+K: Each line contains the amount of money of one of FJ's coins.

* Lines 2+K..1+N+K: These N lines contain the costs of FJ's intended purchases. 

Output

* Line 1: The maximum amount of money FJ can end up with, or -1 if FJ cannot complete all of his purchases.

Sample Input

3 6
12
15
10
6
3
3
2
3
7

INPUT DETAILS: FJ has 3 coins of values 12, 15, and 10. He must make purchases in sequence of value 6, 3, 3, 2, 3, and 7.

Sample Output

12
OUTPUT DETAILS: FJ spends his 10-unit coin on the first two purchases, then the 15-unit coin on the remaining purchases. This leaves him with the 12-unit coin.

HINT

Source

[ Submit][ Status]

状态压缩dp+贪心
K<=16,因此可以采用状压dp求解,枚举硬币使用情况,0<=i<(1<<K),dp[i]表示用当前i所表示的硬币集合做多能够买到第几个的物品,
dp[i]由dp[j={i^(1<<k)},0=<k<K)]转移,二分出用第k个硬币,能在已经买到了第dp[j]个物品的情况下最多能买到第多少个物品,
 当dp[i]=N时,说明,i为一个合法解,此时计算出i中剩余的硬币共值多少钱。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

int dp[1<<17];
int sum[100010];
int coin[17];
int N,K;

using namespace std;

int main()
{
    scanf("%d%d",&K,&N);
    for (int i=0; i<K; i++)
        scanf("%d",&coin[i]);
    for (int i=0; i<N; i++)
    {
        int v;
        scanf("%d",&v);
        sum[i+1] =sum[i]+v;
    }

    int ans=-1;
    for (int i=0; i<(1<<K); i++)
    {
        int best=0;
        int rem=0;
        for (int j=0; j<K; j++)
        {
            int p=1<<j;
            if (i&p)
            {
                int q= sum[ dp[ i ^ p] ];
                int m=upper_bound(sum+1,sum+N+1,q+coin[j])-sum-1;
                if (m>best)
                    best=m;
            }
            else
                rem+=coin[j];
        }
        dp[i]=best;
        if (best==N)
            ans=max(rem,ans);
    }
    printf("%d\n",ans);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值