zju3261 Connections in Galaxy War

Connections in Galaxy War
Time Limit: 3 Seconds      Memory Limit: 32768 KB
In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.


In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.


Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.


Input


There are no more than 20 cases. Process to the end of file.


For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers a, b (0 <= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.


In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.


"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.


"query a" - star a wanted to know which star it should turn to for help


There is a blank line between consecutive cases.


Output


For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.


Print a blank line between consecutive cases.


Sample Input


2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1
Sample Output


1
-1
-1
-1
Author: MO, Luyi

Source: ZOJ Monthly, November 2009




由于需要不断的拆边并需要考虑拆边后的状态,
所以不妨逆序加边。
离线操作,
并查集,每个点 最祖先的点为整个集合的可以连通的点的最大能力点
我们先考虑删完边后的整个图,
对于每个询问,直接查询,
对于每个删边,我们直接加边
最后将保存的答案正序输出即可

#include<cstdio>
#include<cstring>
#include<iostream>
#include<map>
using namespace std;

struct data
{
    int a,b,k,ans;
};

int n,m,q;
int fa[10010],a[10010];
data que[50050];
char s[10];

map < pair<int,int>, int > edge;

int Findset(int x)
{
    return  x == fa[x] ?  x : fa[x]=Findset(fa[x]) ;
}

void Union(int x,int y)
{
    int f1=Findset(x);
    int f2=Findset(y);
    if ( a[f1]> a[f2] || (a[f1]==a[f2]&& f1<f2)  )
        fa[f2]=f1;
    else
        fa[f1]=f2;
}

int main()
{
    int cas=0;
    while ( scanf("%d",&n)!=EOF )
    {
        if (cas++)  printf("\n");
        edge.clear();
        for (int i=0; i<n; i++)
            fa[i]=i;
        for (int i=0; i<n; i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for (int i=1; i<=m; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if (x>y) swap(x, y);
            edge[make_pair( x, y) ]=1;

        }
        scanf("%d",&q);
        //cout<<"---"<<q<<endl;
        for (int i=1; i<=q; i++)
        {
            scanf("%s",s);
            if (s[0]=='d')
            {
                que[i].k=1;
                scanf("%d%d",&que[i].a,&que[i].b);
                if (que[i].a>que[i].b) swap( que[i].a, que[i].b);
                edge[ make_pair(que[i].a, que[i].b)]=0;
            }
            else
            {
                que[i].k=0;
                scanf("%d",&que[i].a);
            }
        }
        map  <pair<int,int>,int> ::iterator it;
        for(it=edge.begin();it!=edge.end();it++)
        {
            if(it->second)
            {
                pair<int,int> tmp=it->first;
                Union(tmp.first,tmp.second);
            }
        }

        for (int i=q; i>=1; i--)
        {
            if (que[i].k==0)
            {
                int f=Findset( que[i].a );
                if (a[f]<= a[ que[i].a ] )
                    que[i].ans=-1;
                else
                    que[i].ans=f;
            }
            else
                Union( que[i].a, que[i].b );
        }
        for (int i=1; i<=q; i++)
            if (que[i].k==0)
                printf("%d\n",que[i].ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ZJU-I型机械臂是一种由浙江大学机器人研究所开发的六自由度机械臂,具有高速、精度和可靠性等特点。机械臂的运动控制是机器人中的重要研究领域之一,其中点到点轨迹规划是机器人在运动过程中最基础和常用的一种方式,也是机械臂控制的核心问题之一。 点到点轨迹规划的目标是通过给定的起点和终点,计算出机械臂的运动轨迹,使机械臂在运动过程中满足机械臂轨迹的连续性、平滑性、可控性等要求。在过去的研究中,经典的点到点轨迹规划方法包括插值法、线性规划法、最小能量法等。 如果使用Python实现机械臂的点到点轨迹规划,可以采用Robotics Toolkit(简称robot)这个模块。robot模块提供了各种从轨迹规划、控制到仿真的功能,可用于ROS、Vrep、Webots等机器人仿真软件。使用robot模块,可以通过几行代码实现机械臂的点到点轨迹规划,例如: ``` from roboticstoolkit import robot from roboticstoolkit.robots import zju # 初始化机器人 zju_arm = robot.Robot('zju', zju.URDF) # 设定起点和终点 start = [0, 0, 0, 0, 0, 0] goal = [0, 1, 1, 0.5, 0, 0] # 计算机械臂的轨迹 path = zju_arm.get_trajectory(start, goal) # 控制机械臂运动到终点 zju_arm.move_to(goal) ``` 其中,`roboticstoolkit`和`roboticstoolkit.robots`都是导入的Python模块,`zju`是机械臂的URDF定义文件,`start`和`goal`是起点和终点的坐标,`get_trajectory()`函数会返回计算得到的机械臂轨迹,`move_to()`函数则控制机械臂运动到终点。 总之,使用Python实现ZJU-I型机械臂的点到点轨迹规划相对简单,只需要导入相应的模块,并根据需要设置机械臂的各种参数,即可轻松实现机械臂的控制。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值