HDU 1113-Word Amalgamation

13 篇文章 0 订阅
Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
 

Input
The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

Sample Input
  
  
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
 

Sample Output
  
  
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******
这道题不是很难,用一个二维字符数组储存字典,主要在输入待检测字符串后遍历字典,将每一个遍历到的字典中的字符串排序,与同样排序后的待检测字符串比较,若排序后的字符串相等,那么就成功解读;
需要注意的是,解读后的字符串可能不止一个,最开始做这道题,我在遍历字典的过程中将每一个复合条件的字符串直接输出,没有考虑顺序,这是错的,需要注意,当解读字符串不止一个的时候,输出时也需要排序,所以我又建了一个二维字符数组d[105][10],用于储存输出字符串,将这个二维数组排序后输出才是对的。
代码如下:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
char dic[105][10];
char s[10];
int cmp( const void *a , const void *b )
{ 
	return strcmp((char *)a,(char *)b);
}
int main(int argc, char *argv[]) 
{
	int i,j,l,n,f;
	char c[10];
	char d[105][10];
	for(n=0;;n++)
	{
		scanf("%s",&dic[n]);
		if(strcmp(dic[n],"XXXXXX")==0)
			break;
	}
	while(scanf("%s",s)!=-1&&strcmp(s,"XXXXXX")!=0)
	{
		f=0;
		qsort(s,strlen(s),sizeof(s[0]),cmp);
		for(i=0;i<n;i++)
		{
			strcpy(c,dic[i]);
			qsort(c,strlen(c),sizeof(c[0]),cmp);
			if(strcmp(s,c)==0)
			{
				strcpy(d[f++],dic[i]);
			}	
		}
		if(f==0)
			printf("NOT A VALID WORD\n");
		else
		{
			qsort(d,f,sizeof(d[0]),cmp);
			for(i=0;i<f;i++)
				printf("%s\n",d[i]);
		}
		printf("******\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值