HDU-6441-Find Integer(费马大定理+勾股数)ʕ •ᴥ•ʔ

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n ,a ,you are required to find 2 integers b ,c such that an +bn=cn .

 

 

Input

one line contains one integer T ;(1≤T≤1000000)

next T lines contains two integers n ,a ;(0≤n≤1000 ,000 ,000,3≤a≤40000)

 

 

Output

print two integers b ,c if b ,c exits;(1≤b,c≤1000 ,000 ,000) ;

else print two integers -1 -1 instead.

 

 

Sample Input

 

1 2 3

 

 

Sample Output

 

4 5

 

题目大意:给出T组测试样例,对于每组测试数据,输入n,a,输出满足a^n+b^n=c^n的b和c,如果没有满足要求的,输出-1 -1;

费马大定理证明了n>2的时候没有整数满足a^n+b^n==c^n;

当n==1时,任意a,1,a+1即可;

当n==2时,即为勾股数,百度百科有证明过程,分为奇数和偶数,然后根据式子直接输出结果即可:

当a为大于1的奇数2n+1时,b=2n^2+2n, c=2n^2+2n+1

当a为大于4的偶数2n时,b=n^2-1, c=n^2+1

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string.h>
//#include <map>
#define ll long long
using namespace std;
#define pai acos(-1,0)
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		ll n,a;
		ll b,c;
		scanf("%lld %lld",&n,&a);
		if(n>2)
		printf("-1 -1\n");
		if(n==1) 
		printf("1 %lld\n",a+1);
		if(n==2)
		{
			if(a%2)
			{
				b=(a-1)*(a-1)/2+a-1;
				c=b+1;
			}
			else
			{
				b=a*a/4-1;
				c=b+2;
			}
			printf("%lld %lld\n",b,c); 
		}
		
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值