hdu 5933 ArcSoft's Office Rearrangement ʕ •ᴥ•ʔ

 

Problem Description

ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K block with equal size, please help him.

 

Input

First line contains an integer T , which indicates the number of test cases.

Every test case begins with one line which two integers N and K , which is the number of old blocks and new blocks.

The second line contains N numbers a1 , a2 , ⋯ , aN , indicating the size of current blocks.

Limits
1≤T≤100
1≤N≤105
1≤K≤105
1≤ai≤105

 

Output

For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can't re-arrange K new blocks with equal size, y equals -1.

 

Sample Input

 

3 1 3 14 3 1 2 3 4 3 6 1 2 3

 

Sample Output

 

Case #1: -1 Case #2: 2 Case #3: 3

 

题意:给你 n 个数 让你经过 差分(任意差分) 结合 (相邻两个相加)

然后自己手推一下 就可以得到以下结论

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string.h>
//#include <map>
#include<vector>
#define ll long long
using namespace std;
#define pai acos(-1,0)
ll a[100010];
int main()
{
	int t;
	scanf("%d",&t);
	int z=1;
	while(t--)
	{
		int n,m;
		cin>>n>>m;
		ll s=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
			s+=a[i];
		}
		if(s%m)
		{
		printf("Case #%d: -1\n",z++);
		continue;
		}
		if(m==1)
		{
		printf("Case #%d: %d\n",z++,n-1);
		continue;
		}
		ll x=s/m;
		ll cnt=0;
		for(int i=1;i<=n;i++)
		{
			if(a[i]>=x&&a[i]%x==0)
			{
				cnt+=a[i]/x-1;
			}
			else
			{
				a[i+1]+=a[i];
				cnt++;
			}
		}
		printf("Case #%d: %lld\n",z++,cnt);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值