亲和串
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18150 Accepted Submission(s): 8017
Problem Description
人随着岁数的增长是越大越聪明还是越大越笨,这是一个值得全世界科学家思考的问题,同样的问题Eddy也一直在思考,因为他在很小的时候就知道亲和串如何判断了,但是发现,现在长大了却不知道怎么去判断亲和串了,于是他只好又再一次来请教聪明且乐于助人的你来解决这个问题。
亲和串的定义是这样的:给定两个字符串s1和s2,如果能通过s1循环移位,使s2包含在s1中,那么我们就说s2 是s1的亲和串。
Input
本题有多组测试数据,每组数据的第一行包含输入字符串s1,第二行包含输入字符串s2,s1与s2的长度均小于100000。
Output
如果s2是s1的亲和串,则输出"yes",反之,输出"no"。每组测试的输出占一行。
Sample Input
AABCD CDAA ASD ASDF
Sample Output
yes no
Author
Eddy
Recommend
lcy | We have carefully selected several similar problems for you: 3336 2201 3068 2202 2200
题解
1 题目要求的是给定字符串s1 和 s2,问s1能否通过移位得到使得s2包含在s1里面。
2 很显然的kmp的模板题,只须在s1后面在添上一个s1即可。
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define N 0x3f3f3f3f
using namespace std;
string s1,s2;
int nexxt[100010];
void getnext()
{
int i=0,j=-1;
nexxt[0]=-1;
while(i<s2.size())
{
if(j==-1||s2[i]==s2[j])
{
nexxt[++i]=++j;
}
else
j=nexxt[j];
}
}
int find()
{
getnext();
int i=0,j=0;
while(i<s1.size())
{
if(j==-1||s1[i]==s2[j])
{
i++,j++;
}
if(j==s2.size())
return 1;
if(s1[i]!=s2[j])
j=nexxt[j];
}
return 0;
}
int main()
{
while(cin>>s1>>s2)
{
s1=s1+s1;
if(find())
{
cout<<"yes"<<endl;
}
else
cout<<"no"<<endl;
}
return 0;
}