POJ3126Prime Path 暴力BFS

POJ3126Prime Path 暴力BFS

传送门

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033

1733

3733

3739

3779

8779

8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3

1033 8179

1373 8017

1033 1033

Sample Output

6

7

0

题目大意:给定两个数,要求从a变到b每次只能变一位数,而且变完之后的数必须是素数(这是控制越界的条件),一开始我并没什么想法,直到zmin提醒到我,暴力,暴力,暴力,暴力枚举每一位,提醒了我,但是还是有一点需要注意的就是,注意在变每一位的时候把他存下来,方便枚举下一位的时候恢复,提醒自己 素数表千万不要打错,素数表千万不要打错,素数表千万不要打错。

//
//  main.cpp
//  whr_bfs
//
//  Created by  41 on 17/8/7.
//  Copyright (c) 2017年 henuwhr. All rights reserved.
//  赵晓宇说我要ac

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <map>
#include <cstring>

using namespace std;
const int maxx = 20005;

int vis[maxx];
int prime[maxx];
int a,b;
void init() ///打N以内的素数表,prime[i]=0为素数。
{
    int i,j;
    memset(prime,0,sizeof(prime));
    prime[1]=1;
    for(i=2; i<maxx; i++)
    {
        if(prime[i]==0)
        {
            for(j=2; j*i<maxx; j++)
                prime[j*i]=1;
        }
    }
}
struct node{
    int x,st;
};

void bfs(int x){
    init();
    queue<node>q;
    node xx,nex;
    xx.x = x;
    xx.st = 0;
    q.push(xx);
    vis[xx.x] = 1;
    while(!q.empty()){
        node p;
        p = q.front();
        q.pop();
        if(p.x==b){
            cout<<p.st<<endl;
            return ;
        }
        int t[6];
        t[1]=p.x/1000;
        t[2]=p.x/100%10;
        t[3]=p.x/10%10;
        t[4]=p.x%10;
        int mm=0;
        for(int i = 1 ; i<=4;i++){
            int xxxx = t[i];//保存原来的。以后方便恢复
            for(int j = 0;j<=9;j++){
                if(t[i]!=j){
                    t[i] = j;
                    mm = t[1]*1000+t[2]*100+t[3]*10+t[4];
                }
                if(mm>=1000&&mm<10000&&!vis[mm]&&!prime[mm]){
                    nex.x = mm;
                    nex.st = p.st+1;
                    q.push(nex);
                    vis[mm] = 1;
                }
            }
            t[i] = xxxx;
        }

    }
    //cout << "Impossible" << endl;
}
int main(int argc, const char * argv[]) {
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--){
        cin>>a>>b;
        memset(vis,0,sizeof vis);
        bfs(a);
    }
    return 0;
}
/*
 3
 1033 8179
 1373 8017
 1033 1033
 */
/*
 6
 7
 0
 */
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值