HDU Problem - 1455 Sticks

题目链接

Problem Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output file contains the smallest possible length of original sticks, one per line.

Sample Input

9

5 2 1 5 2 1 5 2 1

4

1 2 3 4

0

Sample Output

6

5

AC
  • 剪枝的运用
  • 首先从最长的木棒枚举,满足木棒总和是枚举木棒的倍数
  • 然后dfs看能否把所有木棒用完,如果用完就找到了一个最小的合适值
  • 开始剪枝
  • 如果进行一系列的搜索之后,发现当前这个木棒未完成匹配,而且当前所要匹配的是整个目标,这就不用接着往下dfs
    举个例子:木棒分别是 6 5 5 3 2 2, 你要找6, 第一个可以,接着匹配下一个6,找到5时发现没有匹配的这时候直接退出就行,说明6不能构成完整的
#include <bits/stdc++.h>
using namespace std;

int a[65];
bool vis[65];
bool cmp(int a, int b) {
    return a > b;
}
bool dfs(int n, int tar, int temp, int len, int now) {
    if (len == n)   return true;
    if (temp == 0)  temp = tar, now = 0;
    for (int i = now; i < n; ++i) {
        if (vis[i]) continue;
        if (a[i] <= temp) {
            vis[i] = true;
            if (dfs(n, tar, temp - a[i], len + 1, i + 1))
                return true;
            else{
                vis[i] = false;
                if (temp == tar)
                    return false;
            }
        }
    } 
    return false;
}
int main() {
    int n;
    while(scanf("%d", &n), n) {
        int sum = 0;
        for (int i = 0; i < n; ++i) {
            scanf("%d", &a[i]);
            sum += a[i];
        }
        sort(a, a + n, cmp);
        int tar = a[0];
        while (1) {
            memset(vis, false, sizeof(vis));
            while (sum % tar)   tar++;
            if(dfs(n, tar, tar, 0, 0))  break;
            tar++;
        }
        printf("%d\n", tar);
    }
    return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值