pat basic 1028 人口普查

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数 N,取值在(0,105];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

解题思路:

#include <stdio.h>
#include <stdlib.h>

typedef struct _People {
	char name[8];
	int year, month, day;
} People;

int compare(const void *a, const void *b)
{
	const People *pa = a;
	const People *pb = b;
	if ( pa->year!=pb->year ) {
		return pa->year - pb->year;
	} else if ( pa->month!=pb->month ) {
		return pa->month - pb->month;
	} else {
		return pa->day - pb->day;
	}
}

int main(int argc, const char *argv[])
{
	int N, i, j;
	if ( scanf("%d", &N)==EOF ) printf("error\n");
	People people[N];
	People today = {"",2014,9,6};
	People temp;
	
	for ( i=0, j=0; i<N; i++ ) {
		if ( scanf("%s%d/%d/%d", temp.name, &temp.year, &temp.month, &temp.day)==EOF ) printf("error\n");
		if ( temp.year<today.year-200 ) {
			continue;
		} else if ( temp.year==today.year-200 && temp.month<today.month ) {
			continue;
		} else if ( temp.year==today.year-200 && temp.month==today.month && temp.day<today.day ) {
			continue;
		} else if ( temp.year>today.year ) {
			continue;
		} else if ( temp.year==today.year && temp.month>today.month ) {
			continue;
		} else if ( temp.year==today.year && temp.month==today.month && temp.day>today.day ) {
			continue;
		}
		people[j++] = temp;
	}
	
	qsort(people, j, sizeof(people[0]), compare);
	j==0 ? printf("0\n") : printf("%d %s %s\n", j, people[0].name, people[j-1].name) ;
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值