微软2014实习生及秋令营技术类职位在线测试-2_kth string

微软2014实习生及秋令营技术类职位在线测试

题目2 : K-th string

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

Description

Consider a string set that each of them consists of {0, 1} only. All strings in the set have the same number of 0s and 1s. Write a program to find and output the K-th string according to the dictionary order. If such a string doesn’t exist, or the input is not valid, please output “Impossible”. For example, if we have two ‘0’s and two ‘1’s, we will have a set with 6 different strings, {0011, 0101, 0110, 1001, 1010, 1100}, and the 4th string is 1001.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10000), the number of test cases, followed by the input data for each test case.
Each test case is 3 integers separated by blank space: N, M(2 <= N + M <= 33 and N , M >= 0), K(1 <= K <= 1000000000). N stands for the number of ‘0’s, M stands for the number of ‘1’s, and K stands for the K-th of string in the set that needs to be printed as output.

Output

For each case, print exactly one line. If the string exists, please print it, otherwise print “Impossible”.


样例输入
3
2 2 2
2 2 7
4 7 47
样例输出
0101
Impossible
01010111011
package microsoft.kthString;

import java.util.*;

public class Main {
	public static void main(String[] args) {
		Scanner scan = new Scanner(System.in);
		int count = scan.nextInt();
//		Get the number of test cases
		if(!(count>=1&&count<=10000))
			System.exit(0);
//		For every case
		while(count!=0){
			count--;
			int nn = scan.nextInt();
			int mm = scan.nextInt();
			int kth = scan.nextInt();
			if(!(nn>=0&&mm>=0&&nn+mm>=2&&nn+mm<=33&&kth>=1&&kth<=1000000000))
				continue;
//			Calculate the string that is exist or not.
			if(kth>combCount(nn+mm,nn)){
				System.out.println("Impossible");
				continue;
			}
//			Generate the output string
			StringBuilder output = new StringBuilder("");
			while(nn>0&&mm>0){
				if(combCount(nn+mm-1,nn-1)>=kth){
					output.append("0");
					nn--;
				}
				else{
					output.append("1");
					kth -= combCount(nn+mm-1,nn-1);
					mm--;
				}
			}
			if(nn==0)
				for(int i=0; i<mm; i++)
					output.append("1");
			else
				for(int i=0; i<nn; i++)
					output.append("0");
			System.out.println(output);
		}
		scan.close();
	}

	private static int combCount(int n, int k){
		k = (n-k)>k?k:(n-k);
		int mul=1;
		int div=1;
		for(int i=1;i<=k;n--,i++){
			mul *= n;
			div *= i;
		}
		return mul/div;
	}
}

以上代码思想是参考http://blog.csdn.net/yunshuixiliu/article/details/23591953?reload
没有进行测试,不知是否绝对正确。
欢迎指正。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值