【堆】poj2833

47 篇文章 0 订阅

The Average

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1n2 and n (1 ≤ n1n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains npositive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000


大意:给出N个分数,要求去掉n1个最高分,n2个最低分,然后算平均分。

看数据范围明显直接排序是不行的,可以先求总和,同时用一个大根堆和一个小根堆记录下n1个最高分和n2个最低分

总和减去n1个最高分,n2个最低分的和,除以数据个数即可。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;

long n, n1, n2;
priority_queue <long, vector<long>, greater<long> > q1;  //大根堆
priority_queue <long> q2;


int main()
{
    freopen("poj2833.in", "r", stdin);
    scanf("%ld%ld%ld", &n1, &n2, &n);
    while ((n1 != 0) && (n2 != 0) && (n != 0))
    {

        long long sum = 0;
        for (long i = 1; i <= n; i++)
        {
            long t;
            scanf("%d", &t);
            sum += t;
            q1.push(t);
            q2.push(t);
            if (q1.size() > n1) q1.pop();
            if (q2.size() > n2) q2.pop();
        }
        while (!q1.empty())
        {
            sum -= q1.top();
            q1.pop();
        }
        while (!q2.empty())
        {
            sum -= q2.top();
            q2.pop();
        }
        double ave = (1.0 * sum) / (n - n1 - n2);
        printf("%.6lf\n", ave);
        scanf("%ld%ld%ld", &n1, &n2, &n);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值