Uva 1587 白书第三章 盒子Box

1587 Box

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden
boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular
parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side
of the box.

Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan
pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of
time to explain Joe that he has made a mistake.
Fortunately, Joe adores everything related to computers and sincerely believes that computers never
make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program
that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.
Input
Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet
and contains two integer numbers and (1 ≤ w, h ≤ 10000) — width and height of the pallet in
millimeters respectively.
Output
For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is
possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not
possible to do so.
Sample Input
1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234
Sample Output
POSSIBLE

IMPOSSIBLE

好 我们这么看待这个问题

把长方体的展开图画出来 会得到 所有情况 举个例子 所有边都相等(此时是立方体)

那有四条边相等的情况有三种 正好也是一个长方体

六个边相等情况两种 也是一个长方体 ......

注意画展开图 边想不想等用map实现 然后判断输入是不是两边相等要特判 因为

3 2

3 2

3 2

3 2

2 3

2 3

是可以的

但是

2 2

3 3

3 2

3 2

2 3

2 3

是不行的 Ps(展开图是初中数学学的展开成六个小格子的图)

详情见代码吧

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
map<int ,int > m1;

int num[25];
int main(){
    int a,b,flag=0;
    int Kase = 0;
    while(scanf("%d%d",&a,&b)==2){
            if(a==b) flag++;
            m1[a]++;
            m1[b]++;
            Kase++;
           if(Kase%6==0){
            memset(num,0,sizeof(num));
             for(map<int,int>::iterator it=m1.begin();it!=m1.end();++it)
           {
        num[it->second]++;
           }
           if(num[4]==3&&!flag||(num[4]==1&&num[6]==1&&num[2]==1&&!flag)||(num[6]==2&&flag==0)||(flag==6)||(flag==2&&num[8]==1&&num[4]==1)){
              printf("POSSIBLE\n");
           }
           else printf("IMPOSSIBLE\n");
            m1.clear();
            flag = 0;
           }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值