POJ 1088 滑雪

http://acm.pku.edu.cn/JudgeOnline/problem?id=1088 

滑雪
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17699 Accepted: 5803

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

 

解答:

#include<stdio.h>
#include<stdlib.h>

int h[100][100];
int p[100][100];
int r,c;

int getMaxPath(int i,int j){
    int temp,max;

    if(p[i][j] != -1)
        return p[i][j];
    max = 0;
    if(i>0 && h[i][j]>h[i-1][j] ){
        temp = getMaxPath(i-1,j);
        max = max>temp?max:temp;
    }
    if(j>0 && h[i][j]>h[i][j-1] ){
        temp = getMaxPath(i,j-1);
        max = max>temp?max:temp;
    }
    if(i<r-1 && h[i][j]>h[i+1][j]){
        temp = getMaxPath(i+1,j);
        max = max>temp?max:temp;
    }
    if(j<c-1 && h[i][j]>h[i][j+1] ){
        temp = getMaxPath(i,j+1);
        max = max>temp?max:temp;
    }
    p[i][j] = max+1;
    return p[i][j];
}

int main(){
    int i,j,t,maxPath;
    scanf("%d%d",&r,&c);
    for(i=0;i<r;i++){
        for(j=0;j<c;j++){
            scanf("%d",&h[i][j]);
            p[i][j] = -1;
        }
    }
    
    maxPath = 0;
    for(i=0;i<r;i++){
        for(j=0;j<c;j++){
            t = getMaxPath(i,j);
            if(t>maxPath)
                maxPath = t;
        }
    }
    printf("%d ",maxPath);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值