hdoj 1874 畅通工程 vector邻接表测试


畅通工程续

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41314    Accepted Submission(s): 15259


Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
  
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
  
  
2 -1
 

Author
linle
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2544  2066  2112  1217  1875 



经典的SPFA算法,额,只是为了测试一下新的图储存方法。


//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<string>
#include<sstream>
#include<cstdlib>
#include<cstring>
#include<cctype>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<deque>
#include<cmath>
#include<climits>
#include<list>
#include<utility>
#include<memory>
#include<cstddef>
#include<iterator>
#include<iomanip>
#define _ ios_base::sync_with_stdio(0);cin.tie(0);
using namespace std;
typedef long long LL;
typedef long double LD;
const double pi = acos(-1.0);
///


struct edge {
	int to;
	int len;
	edge(int _to, int _len) {
		to = _to;
		len = _len;
	}
};

vector<edge>st[1007];

int inque[307];
int dis[307];

///
int main(int argc, char**argv) {
	//freopen("input.txt", "r", stdin);、
	//freopen("output.txt", "w", stdout);
	

	int M, N;
	while(cin>>N>>M){
		for (int i = 0; i < N; i++) {
			if(!st[i].empty()) st[i].clear();
			dis[i] = 999999;
		}
		//memset(mar, 0, sizeof(mar));
		memset(inque, 0, sizeof(inque));
		
		for (int i = 0; i < M; i++) {
			int a;
			int b;
			int c;
			cin >> a >> b >> c;
			st[a].push_back(edge(b,c));
			st[b].push_back(edge(a,c));
		}
		int start;
		int end;
		cin >> start >> end;

		queue<int>Q;
		Q.push(start);
		inque[start] = 1;
		dis[start] = 0;
		while (!Q.empty()) {
			int here = Q.front();
			Q.pop();
			inque[here] = 0;
			int k = 0;
			while (k <st[here].size()) {
				int T = st[here][k].to;
				int L = st[here][k].len;
				
				if (dis[T] > dis[here] + L) {
					dis[T] = dis[here] + L;
					if (inque[T] == 0) {
						Q.push(T);
						inque[T] = 1;
					}
				}
				k++;
			}
		}
		if (dis[end] != 999999)
			cout << dis[end] << endl;
		else
			cout << "-1\n";
	}






	
	//system("pause");
	return 0;
}

//END



另外一种方法,比较类似


//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<string>
#include<sstream>
#include<cstdlib>
#include<cstring>
#include<cctype>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<deque>
#include<cmath>
#include<climits>
#include<list>
#include<utility>
#include<memory>
#include<cstddef>
#include<iterator>
#include<iomanip>
#define _ ios_base::sync_with_stdio(0);cin.tie(0);
using namespace std;
typedef long long LL;
typedef long double LD;
const double pi = acos(-1.0);
///
const int maxn = 205;
vector<pair<int, int> >E[maxn];
int n, m;
int d[maxn], inq[maxn];

void init() {
	for (int i = 0; i < maxn; i++) {
		E[i].clear();
		inq[i] = 0;
		d[i] = 1e9;
	}
}

///
int main(int argc, char**argv) {
	//freopen("input.txt", "r", stdin);、
	//freopen("output.txt", "w", stdout);
	


	while (cin >> n >> m) {
		init();
		for (int i = 0; i < m; i++) {
			int x, y, z;
			cin >> x >> y >> z;
			E[x].push_back(make_pair(y, z));
			E[y].push_back(make_pair(x, z));
		}

		int s, t;
		cin >> s >> t;

		queue<int>Q;

		Q.push(s), d[s] = 0, inq[s] = 1;
		while (!Q.empty()) {
			int now = Q.front();
			Q.pop(); inq[now] = 0;
			for (int i = 0; i < E[now].size(); i++) {
				int v = E[now][i].first;
				if (d[v] > d[now] + E[now][i].second) {
					d[v] = d[now] + E[now][i].second;
					if (inq[v] == 0) {
						inq[v] = 0;
						Q.push(v);
					}
				}
			}
		}
		if (d[t] == 1e9) cout << "-1\n";
		else cout << d[t] << endl;

	}

	
	






	
	//system("pause");
	return 0;
}

//END









  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值