Oil Deposits

题目描述

 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

输入

 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

输出

 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

样例输入

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

样例输出

0
1
2
2
//AC
/*
此题的中心思想与 NYOJ 27 水池数目 一致 只不过一个判断四个方向
一个判断八个方向
*/ 
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int px[8]={0,0,-1,1,1,1,-1,-1};//分别从八个方向开始判断 
int py[8]={-1,1,0,0,1,-1,-1,1};
char a[105][105];
int ans;
void dfs(int x,int y)
{
	for(int i=0;i<8;i++)
	{
		int fx=x+px[i];
		int fy=y+py[i];
		if(a[fx][fy]=='@')
		{
			a[fx][fy]='*';
			dfs(fx,fy);
		}
	}
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0)break;
		getchar();
		memset(a,'*',sizeof(a));
		ans=0;
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		cin>>a[i][j];//之前用scanf输入 答案总是错误 换成cin 一次通过 
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			if(a[i][j]=='@')
			{
				a[i][j]='*';//使用过 将其变为'*' 
				dfs(i,j);//开始搜索 
				ans++;//每一次的深搜 结束 ans+1 
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值