题目描述
给出一个数据序列,使用希尔排序算法进行降序排序。
间隔gap使用序列长度循环除2直到1
输入
第一行输入t,表示有t个测试示例 第二行输入n,表示第一个示例有n个数据(n>1) 第三行输入n个数据,都是正整数,数据之间用空格隔开
以此类推输出
对每组测试数据,输出每趟排序结果。不同组测试数据间用空行分隔。
样例输入
2
6
111 22 6 444 333 55
8
77 555 33 1 444 77 666 2222
样例输出
444 333 55 111 22 6
444 333 111 55 22 6
444 555 666 2222 77 77 33 1
666 2222 444 555 77 77 33 1
2222 666 555 444 77 77 33 1
解题思路推荐看B站up 懒猫老师的 https://www.bilibili.com/video/BV1N54y1y7Wo?from=articleDetail
https://www.bilibili.com/read/cv8013121
↑目录
#include<iostream>
#include<string>
using namespace std;
int main() {
int t;
int arr[100];
cin>>t;
while(t--) {
int n;
cin>>n;
for(int i = 1 ; i <= n; i++) {
cin>>arr[i];
}
for(int d = n / 2; d >= 1; d = d/2){
for(int i = 1 + d; i <= n; i++){
arr[0] = arr[i];
int j = i - d;
while(j > 0 && arr[0] > arr[j] ){
arr[j + d] = arr[j];
j = j - d;
}
arr[j + d] = arr[0];
}
for(int i = 1; i <= n; i++){
cout<<arr[i]<<" ";
}
cout<<endl;
}
cout<<endl;
}
return 0;
}