hdu 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59834    Accepted Submission(s): 13613


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
  
5 6 -1 5 4 -7 
7 0 6 -1 1 -6 7 -5
 

Sample Output
 
  
Case 1: 14 1 4 

Case 2: 7 1 6
  这是DP的经典之一,欲求出一个最优的结果,但不暴力地去枚举。

如一个序列:6,-1,5,4,-7 求它的连续最大段就是:(-1) 14.

DP的方法只要一重的循环就可以把这道题搞定:

每一次的计算对前一次结果不会有影响,这是DP的特点。

这样之要从第一个开始计算,-1 -7 的最大值分别是 10 14 7

如果计算过程中值出现小于零的情况那就将值归零。

#include<stdio.h>
int main()
{
int T,n,a[100005];
int i,j,temp,first,last,sum,maxnum=-100000;
scanf("%d",&T);
for(i=1;i<=T;i++)
{
sum=0;
temp=1;
maxnum=-100000;
scanf("%d",&n);
for(j=0;j<n;j++)
scanf("%d",&a[j]);
for(j=0;j<n;j++)
{
sum+=a[j];
if(sum>maxnum)
{
maxnum=sum;
first=temp;
last=j+1;
}
if(sum<0)
{
sum=0;
temp=j+2;
}
}
printf("Case %d:\n",i);
if(i!=T)
printf("%d %d %d\n\n",maxnum,first,last);
else printf("%d %d %d\n",maxnum,first,last);
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值