HDOJ 1701 ACMer (对于浮点数计算的理解 水题)

ACMer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4763    Accepted Submission(s): 2232


Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

Output
For each test case, output the minumal number of students in HDU.
 

Sample Input
  
  
1 13.00 14.10
 

Sample Output
  
  
15
 

Source

2007省赛集训队练习赛(1) 


思路:

也是水题。。。就是遍历,看这个数×a%和×b%所得的两个小数之间有没有整数。如果有那就说明存在一个解。

WA的点就是对浮点数的计算没搞明白。。。。


我到现在都还没搞明白这两个方法算出来的m2和n2为什么不相同。。第一种办法WA了半小时,改成第二种算法就过了。。


代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		double m,n;
		cin>>m>>n;
		for(int i=1;;i++)
		{
			int m2=m*i/100;
			int n2=n*i/100;
			//cout<<m<<" "<<n<<" "<<m1<<" "<<n1<<" "<<m2<<" "<<n2<<endl;
			if(m2<n2)
			{
				cout<<i<<endl;
				break;
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值