PAT甲级 -- 1131 Subway Map (30 分)

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.

subwaymap.jpg

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 100), the number of subway lines. Then N lines follow, with the i-th (i=1,⋯,N) line describes the i-th subway line in the format:

M S[1] S[2] ... S[M]

where M (≤ 100) is the number of stops, and S[i]'s (i=1,⋯,M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order -- that is, the train travels between S[i] and S[i+1] (i=1,⋯,M−1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called "transfer stations"), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (≤ 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.

samplemap.jpg

Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi's are the line numbers and Si's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

思考了,难点就在线路的存储上面,很难...

完全没什么思路, 参考了柳神的代码,加了点注释:

 等明天自己写一遍!

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;

vector<vector<int>> v(10000);
int visit[10000], minCnt, minTransfer, start, end1;
unordered_map<int, int> line;
vector<int> path, tempPath;


int transferCnt(vector<int> a) {  //把路径上的经换乘站计算出来
	int cnt = -1, preLine = 0;  //cnt=-1,第一站不计算在内
	for (int i = 1; i < a.size(); i++) {
		if (line[a[i-1]*10000+a[i]] != preLine) cnt++;  //和前一条线不一样,需换乘
		preLine = line[a[i-1]*10000+a[i]];
	}
	return cnt;
}


void dfs(int node, int cnt) {
	if (node == end1 && (cnt < minCnt || (cnt == minCnt && transferCnt(tempPath) < minTransfer))) {
		minCnt = cnt;
		minTransfer = transferCnt(tempPath);
		path = tempPath;
	}


	if (node == end1) return;

	for (int i = 0; i < v[node].size(); i++) {  //node可以到的车站
		if (visit[v[node][i]] == 0) { //该车站没访问过
			visit[v[node][i]] = 1;
			tempPath.push_back(v[node][i]);
			dfs(v[node][i], cnt + 1); //经停站+1
			visit[v[node][i]] = 0;  //回溯
			tempPath.pop_back();
		}
	}
}


int main() {
	int n, m, k, pre, temp; // n个站,每条线的经停站,k个查询,pre是前一站,temp是后一站
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d%d", &m, &pre);
		for (int j = 1; j < m; j++) {
			scanf("%d", &temp);
			v[pre].push_back(temp); //pre能到的站
			v[temp].push_back(pre);  //temp能到的站
			line[pre*10000+temp] = line[temp*10000+pre] = i + 1;  //例如pre为3001, temp为2450 则line[30012450]=x,x即为经过的地铁线
			pre = temp;
		}
	}


	scanf("%d", &k);
	for (int i = 0; i < k; i++) {
		scanf("%d%d", &start, &end1);
		minCnt = 99999, minTransfer = 99999;  //minCnt是经停站,minTransfer是换乘站
		tempPath.clear();  //每次查询,清空路径
		tempPath.push_back(start); //把第一站放进去
		visit[start] = 1;  //第一站标记访问
		dfs(start, 0);  //经停站是0
		visit[start] = 0;  //恢复
		printf("%d\n", minCnt);

		int preLine = 0, preTransfer = start;

		for (int j = 1; j < path.size(); j++) {  //最终的路线
			if (line[path[j-1]*10000+path[j]] != preLine) {  //和前一站不一样,需要换乘
				if (preLine != 0) printf("Take Line#%d from %04d to %04d.\n", preLine, preTransfer, path[j-1]);  //只有一条线,不会输出这个
				preLine = line[path[j-1]*10000+path[j]];
				preTransfer = path[j-1];
			}
		}
		printf("Take Line#%d from %04d to %04d.\n", preLine, preTransfer, end1);
	}
	return 0;
}

自己又写了一遍:

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;

vector<vector<int>> v(10010);
unordered_map<int, int> lines;
bool vis[10010] = {false};  //访问数据
vector<int> tempPath, path;

int minCnt, minTransfer = 0;
int startl, end1;

int transferCnt(vector<int> a)
{
	int cnt = -1, preline  = 0;
	for (int i = 1; i < a.size(); i++)
	{
		if (lines[a[i-1]*10000+a[i]] != preline)
		{
			cnt++;
		}
		preline = lines[a[i-1]*10000+a[i]];
	}
	return cnt;
	
}

void dfs(int node, int cnt)
{
	if(node == end1 && (cnt < minCnt || (cnt == minCnt && transferCnt(tempPath) < minTransfer)))
	{
		minCnt = cnt;
		minTransfer = transferCnt(tempPath);
		path = tempPath;
	}

	if(node == end1) return;

	for (int i = 0; i < v[node].size(); i++)
	{
		if(vis[v[node][i]] == false)
		{
			vis[v[node][i]] = true;
			tempPath.push_back(v[node][i]);
			dfs(v[node][i], cnt+1);
			vis[v[node][i]] = false;
			tempPath.pop_back();
		}
	}
}

int main()
{
	int n, m, k, pre, post;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d %d", &m, &pre);
		for(int j = 1; j < m; j++)
		{
			scanf("%d", &post);
			v[pre].push_back(post);
			v[post].push_back(pre);
			lines[pre*10000+post] = lines[post*10000+pre] = i+1; 
			pre = post;
		}
	}
	
	scanf("%d", &k);
	for (int i = 0; i < k; i++)
	{
		minCnt = 99999, minTransfer = 99999;
		scanf("%d %d", &startl, &end1);
		tempPath.clear();
		tempPath.push_back(startl);
		vis[startl] = true;
		dfs(startl,0);
		vis[startl] = false;
		printf("%d\n", minCnt);

		int preline = 0, preTransfer = startl;

		for (int j = 1; j < path.size(); j++)
		{
			if (lines[path[j-1]*10000+path[j]] != preline)
			{
				if (preline!=0)
				{
					printf("Take Line#%d from %04d to %04d.\n", preline, preTransfer, path[j-1]);
				}
				preline = lines[path[j-1]*10000+path[j]];
				preTransfer = path[j-1];
			}	
		}
		printf("Take Line#%d from %04d to %04d.\n", preline, preTransfer, end1);
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值