PAT甲级 -- 1119 Pre- and Post-order Traversals (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

拿到题的思路:

1. 前序+后序不能唯一确定一棵树

2. 验算了一下给的案例,案例二中不能确定最后的4号结点的左右位置。可以假设任何一种情况。

3. 一般解决树的问题都是递归解决,一般需要知道给定两个序列的开始位置和结束位置。但是这中间的关系要想清楚还是挺难的!

4. 简单写了一下,在序列的位置处想错,没写出来,去借鉴柳神的代码:

 

柳神思路:

1. 用unique标记是否唯一,如果为true就表示中序是唯一的~

2. 如果发现了一个无法确定的状态,置unique = false,题目只需要输出一个方案,假定这个不可确定的孩子的状态是右孩子

3. 左右孩子划分:前序的开始的第一个应该是后序的最后一个是相等的,这个结点就是根结点。

以后序的根结点的前面一个结点作为参考,寻找这个结点在前序的位置(右子树根节点),就可以根据这个位置来划分左右孩子,递归处理~

#include <iostream>
#include <vector>
#include <cmath>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;

bool flag = true;
int n;
vector<int> preOrder, postOrder, inOrder;


void build(int prel, int prer, int postl, int postr){
	if(prel == prer) {
		inOrder.push_back(preOrder[prel]);
		return;
	}
	if(preOrder[prel] == postOrder[postr]){
		int i = prel+1;
		while(i <= prer && postOrder[postr-1] != preOrder[i]) i++;
		if(i - prel > 1) build(prel+1, i-1, postl, postl+(i-prel-1)-1);  //左
		else
			flag = false;
		inOrder.push_back(postOrder[postr]); //根
		build(i,prer,postl + (i-prel-1), postr-1);  //右
	}
	

}
int main(){
	scanf("%d", &n);
	preOrder.resize(n);
	postOrder.resize(n);
	for(int i = 0; i < n; i++) scanf("%d", &preOrder[i]);
	for(int i = 0; i < n; i++) scanf("%d", &postOrder[i]);
	build(0,n-1,0,n-1);
	printf("%s\n%d", flag == true ? "Yes" : "No", inOrder[0]);
	for (int i = 1; i < inOrder.size(); i++)
		printf(" %d", inOrder[i]);
	printf("\n");
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值