PAT甲级 -- 1151 LCA in a Binary Tree (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

我的思路:

1. 初看这道题,打算把树建出来,然后递归寻找

2. 下午补自己再写一遍的代码:

自己又照着这个思路写了一遍,出问题出在了考虑一边一个的时候只考虑了一个地方

#include <iostream>
#include <map>
#include <vector>
using namespace std;

map<int, int> pos;
int M, N;
vector<int> inorder;
vector<int> preorder;

void LCA(int inl, int inr, int preRoot, int u, int v){
	if (inl > inr) return;
	int inRoot = pos[preorder[preRoot]], uIN = pos[u], vIN = pos[v];
	if (uIN < inRoot && vIN < inRoot)
		LCA(inl, inRoot-1, preRoot+1,u,v);
	else if((uIN < inRoot && vIN > inRoot) || (uIN > inRoot && vIN < inRoot))  //这个地方注意!!
		printf("LCA of %d and %d is %d.\n", u, v, inorder[inRoot]);
	else if(uIN > inRoot && vIN > inRoot)
		LCA(inRoot+1, inr, preRoot+1+(inRoot - inl), u, v);
	else if(uIN == inRoot)
		printf("%d is an ancestor of %d.\n",u, v);
	else if(vIN == inRoot)
		printf("%d is an ancestor of %d.\n",v, u);

}
int main(){
	scanf("%d %d", &M, &N);
	inorder.resize(N+1), preorder.resize(N+1);
	for (int i = 1; i <= N; i++){
		scanf("%d", &inorder[i]);
		pos[inorder[i]] = i;
	}
	for (int i = 1; i <= N; i++) scanf("%d", &preorder[i]);
	int u, v;
	for (int i = 0; i < M; i++){
		scanf("%d %d", &u, &v);
		if (pos[u] == 0 && pos[v] == 0){
			printf("ERROR: %d and %d are not found.\n", u, v);
		}else if(pos[u] == 0 || pos[v] == 0){
			printf("ERROR: %d is not found.\n", pos[u] == 0? u:v);
		}else{
			LCA(1,N,1,u, v);
		}
	}


	return 0;
};

 

柳神代码:

看了柳神的代码说不用建树:

1. 如果a、b同在左子树,根据树递归的性质,递归在左子树中继续找

2. 如果a、b正好一个在左边,一个在右边,则当前根节点就是共同祖先

3. 如果a、b同在右子树,递归在右子树中继续找

4. 正好某一个是另一个的祖先,则直接打印

5. 对不存在的结点的处理方法是 : 用pos map,记录中序中各个key所对应的下标。如果该值下标为0,说明不存在

 

pos数组这点要学习,可以快速找到先序中根节点在中序中的位置!很棒!!

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, int> pos;
vector<int> in, pre;
void lca(int inl, int inr, int preRoot, int a, int b) {
	if (inl > inr) return;
	int inRoot = pos[pre[preRoot]], aIn = pos[a], bIn = pos[b];
	if (aIn < inRoot && bIn < inRoot)  //a、b都在左子树中
		lca(inl, inRoot-1, preRoot+1, a, b);  //递归在左子树中找
	else if ((aIn < inRoot && bIn > inRoot) || (aIn > inRoot && bIn < inRoot))  //a、b在两边,祖先正好是当前根
		printf("LCA of %d and %d is %d.\n", a, b, in[inRoot]);
	else if (aIn > inRoot && bIn > inRoot)  //a、b都在右子树中
		lca(inRoot+1, inr, preRoot+1+(inRoot-inl), a, b);  //递归在右子树中找
	else if (aIn == inRoot) 
		printf("%d is an ancestor of %d.\n", a, b);
	else if (bIn == inRoot)
		printf("%d is an ancestor of %d.\n", b, a);
}
int main() {
	int m, n, a, b;
	scanf("%d %d", &m, &n);
	in.resize(n + 1), pre.resize(n + 1);
	for (int i = 1; i <= n; i++) {
		scanf("%d", &in[i]);
		pos[in[i]] = i; //记录是否出现过
	}
	for (int i = 1; i <= n; i++) scanf("%d", &pre[i]);
	for (int i = 0; i < m; i++) {
		scanf("%d %d", &a, &b);
		if (pos[a] == 0 && pos[b] == 0)
			printf("ERROR: %d and %d are not found.\n", a, b);
		else if (pos[a] == 0 || pos[b] == 0)
			printf("ERROR: %d is not found.\n", pos[a] == 0 ? a : b);
		else
			lca(1, n, 1, a, b);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
使用 JavaScript 编写的记忆游戏(附源代码)   项目:JavaScript 记忆游戏(附源代码) 记忆检查游戏是一个使用 HTML5、CSS 和 JavaScript 开发的简单项目。这个游戏是关于测试你的短期 记忆技能。玩这个游戏 时,一系列图像会出现在一个盒子形状的区域中 。玩家必须找到两个相同的图像并单击它们以使它们消失。 如何运行游戏? 记忆游戏项目仅包含 HTML、CSS 和 JavaScript。谈到此游戏的功能,用户必须单击两个相同的图像才能使它们消失。 点击卡片或按下键盘键,通过 2 乘 2 旋转来重建鸟儿对,并发现隐藏在下面的图像! 如果翻开的牌面相同(一对),您就赢了,并且该对牌将从游戏中消失! 否则,卡片会自动翻面朝下,您需要重新尝试! 该游戏包含大量的 javascript 以确保游戏正常运行。 如何运行该项目? 要运行此游戏,您不需要任何类型的本地服务器,但需要浏览器。我们建议您使用现代浏览器,如 Google Chrome 和 Mozilla Firefox, 以获得更好、更优化的游戏体验。要玩游戏,首先,通过单击 memorygame-index.html 文件在浏览器中打开游戏。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值