PAT A1002. A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
 
 
/**********************侯尼玛*******************/
用map就可以很轻松地写出来,但是提交之后只对了前三个测试例,费解很久。
为了不浪费时间,最后还是去牛客网上试了测试例,发现是因为系数为0的项应该被及时去除。知道这个原因后稍作修改就AC了。
另外我在想这样遇到困难就去查测试例的习惯是不是很不好……但是另一方面又觉得为了一个无关算法的点想很久又想不出来,实在浪费时间。
最后附上代码:
#include <stdio.h>
#include <map>
using namespace std;

int main()
{
    map<int,double> mp;
    int N1,N2;
    while(scanf("%d",&N1)!=EOF)
    {
        int ExponentNum=0;
        for(int i=0;i<N1;i++)
        {
            int Exponent;
            double Coefficient;
            scanf(" %d %lf",&Exponent,&Coefficient);

            if(mp[Exponent]==0)
                ExponentNum++;
            mp[Exponent]+=Coefficient;
        }
        scanf("%d",&N2);
        for(int i=0;i<N2;i++)
        {
            int Exponent;
            double Coefficient;
            scanf(" %d %lf",&Exponent,&Coefficient);
            /****
            if(mp[Exponent]==0)
                ExponentNum++;
            mp[Exponent]+=Coefficient;
            ****/
            if(mp.find(Exponent)==mp.end())
            {
                ExponentNum++;
                mp[Exponent]=Coefficient;
            }
            else
            {
                mp[Exponent]+=Coefficient;
                if(mp[Exponent]==0)
                {
                    ExponentNum--;
                    mp.erase(Exponent);
                }
            }
        }
        printf("%d",ExponentNum);
        for(map<int, double>::iterator it= mp.end();it!=mp.begin();)
        {
            it--;
            printf(" %d %.1f",it->first,it->second);
        }

    }
    return 0;
}


 
 
 
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值